Search found 17 matches

by mrBlaQ
2012-02-24T15:30:54-07:00
Forum: MagickWand
Topic: Undefined reference error while compiling 1.0.9
Replies: 2
Views: 11999

Undefined reference error while compiling 1.0.9

I get...

Code: Select all

undefined reference to `MagickSetImageEndian'


...when running 'make' on the 1.0.9 version. 1.0.8 compiles just fine using the same install steps as outlined on http://www.magickwand.org/

What might I be able to do to overcome this missing reference?

Thanks.
by mrBlaQ
2009-04-21T15:41:17-07:00
Forum: MagickWand for PHP
Topic: Image rotating not working with PNG alpha'd images
Replies: 3
Views: 31598

Re: Image rotating not working with PNG alpha'd images

Hahahaha! Ok... So it was a version compatibility issue I guess. I had to upgrade from MagickWand 1.0.6 to 1.0.8 and ImageMagick from 6.5.0 to 6.5.1 I'm still puzzled on how a function who's syntax has remained unchanged could be effected by minor version updates. Nonetheless, my problem is solved!
by mrBlaQ
2009-04-21T15:18:17-07:00
Forum: MagickWand for PHP
Topic: Image rotating not working with PNG alpha'd images
Replies: 3
Views: 31598

Re: Image rotating not working with PNG alpha'd images

It may help to have a more succinct example. Here's the original image: http://img220.imageshack.us/img220/7190/awesomex.png The convert command I'm trying to emulate is: convert awesome.png -matte -background none -rotate 30 rotate_trans.png ... and it's output is: http://img87.imageshack.us/img87/...
by mrBlaQ
2009-04-21T12:43:28-07:00
Forum: MagickWand for PHP
Topic: Image rotating not working with PNG alpha'd images
Replies: 3
Views: 31598

Image rotating not working with PNG alpha'd images

Code that used to be working is no longer probably due to an upgrade of ImageMagick. I think.... I've have code to rotate PNG alpha transparency images. Where it used to correctly leave the excess 'new' areas transparent, it now leaves them as solid black. This picture would be the best example. I'm...
by mrBlaQ
2009-01-05T14:46:15-07:00
Forum: MagickWand for PHP
Topic: convert +level-colors equivalent in MagickWand
Replies: 1
Views: 8701

Re: convert +level-colors equivalent in MagickWand

My best solution seems too involved. But, here it is:

Load image $a
Create copy $b
Fill $a with new color (MW_ResetMethod)
Separate alpha mask from $b
Invert $b
Composite $b on to $a (MW_CopyOpacityCompositeOp)
Save a$
by mrBlaQ
2009-01-05T12:20:10-07:00
Forum: MagickWand for PHP
Topic: why the gif is faster in ie than in firefox ?
Replies: 2
Views: 10389

Re: why the gif is faster in ie than in firefox ?

I believe IE ignores the framerate values per frame that every other browser and image program do pay attention to.
by mrBlaQ
2009-01-05T12:10:59-07:00
Forum: MagickWand for PHP
Topic: convert +level-colors equivalent in MagickWand
Replies: 1
Views: 8701

convert +level-colors equivalent in MagickWand

I see the +level-colors flag was added to convert about a week after the latest version of MagickWand. I really need this functionality in MW. Does anyone know if there is an equivalent function in MW? What I'm trying to do is take a PNG with some plain white text on it and a mask around that text a...
by mrBlaQ
2009-01-05T12:03:08-07:00
Forum: MagickWand for PHP
Topic: Merge hundreds of file into one
Replies: 3
Views: 14614

Re: Merge hundreds of file into one

I think that question lies outside the realm of this support board. I'll say that I think you need to pay attention to the use of this montage. Do they need to be generated live? Could you pre-render a bunch and just have them handy for a user's http request? Basically, the idea is, why have the cus...
by mrBlaQ
2008-02-19T16:18:14-07:00
Forum: MagickWand for PHP
Topic: Problem trying to convert a JPG to PNG and add an alpha mask
Replies: 1
Views: 9174

Solved

I needed to add...

Code: Select all

MagickSetImageType($wnd, MW_TrueColorMatteType);
Before my MagickEvaluateImage() function.
by mrBlaQ
2008-02-19T16:11:55-07:00
Forum: MagickWand for PHP
Topic: Defining alpha
Replies: 2
Views: 11668

Solved

wait, I'm replying to the wrong thread....
by mrBlaQ
2008-02-19T16:00:09-07:00
Forum: MagickWand for PHP
Topic: Problem trying to convert a JPG to PNG and add an alpha mask
Replies: 1
Views: 9174

Problem trying to convert a JPG to PNG and add an alpha mask

I'm trying to convert a JPG to a PNG and add an alpha mask. Here's the code I have currently. My script dies during MagickSetImageAlphaChannel and error_reporting(E_ALL) doesn't say why. MagickSetImageFormat($wnd, "PNG32"); error_log("MagickSetImageFormat", 0); MagickSetImageAlphaChannel($wnd, MW_Ac...
by mrBlaQ
2008-02-05T14:43:55-07:00
Forum: MagickWand for PHP
Topic: MagickSetImageOpacity is an undefined function
Replies: 3
Views: 13120

Re: MagickSetImageOpacity is an undefined function

When there's a will, there's a way. I've discovered that I can set the opacity of my top layer image with the following syntax:

Code: Select all

MagickEvaluateImage($wnd, MW_DivideEvaluateOperator, (100/$alpha), MW_AlphaChannel);
by mrBlaQ
2008-02-05T14:42:11-07:00
Forum: MagickWand
Topic: MagickSetImageOpacity behavior
Replies: 9
Views: 28175

Re: MagickSetImageOpacity behavior

The equivalent MagickWand PHP syntax is the following

Code: Select all

MagickEvaluateImage($wnd, MW_DivideEvaluateOperator, (100/$alpha), MW_AlphaChannel);
by mrBlaQ
2008-02-05T13:25:07-07:00
Forum: MagickWand for PHP
Topic: MagickSetImageOpacity is an undefined function
Replies: 3
Views: 13120

Re: MagickSetImageOpacity is an undefined function

I answered my first problem. I had to add the following code... ZEND_FE( magicksetimageopacity, NULL ) right before ZEND_FE( magicksetimageoption, NULL ) in magickwand.c I recompiled MagickWand and it seems to work now. I'm still interested in my followup question about the 'missing' argument value....
by mrBlaQ
2008-02-05T13:08:20-07:00
Forum: MagickWand for PHP
Topic: MagickSetImageOpacity is an undefined function
Replies: 3
Views: 13120

Re: MagickSetImageOpacity is an undefined function

My followup question, To me it seems MagickCompositeImage should have an 'argument' variable. Why doesn't it, or how can I set one? I basically want to accomplish the example here: http://www.imagemagick.org/Usage/compose/#dissolve