Search found 15 matches

by djeyewater
2016-01-14T02:06:18-07:00
Forum: Users
Topic: Installing Ghostscript delegate - no lib or include?!
Replies: 0
Views: 3792

Installing Ghostscript delegate - no lib or include?!

I don't understand how to build the Ghostscript delegate lib - I've tried the version on ImageMagick's delegates download page, and also the latest version from the Ghostscript website. Both when built only contain a bin and share dir, no include or lib dir. (I'm installing to a non-standard locatio...
by djeyewater
2013-09-07T08:30:19-07:00
Forum: Users
Topic: thumbnail file size
Replies: 3
Views: 2704

Re: thumbnail file size

Thanks for the answer, it seems obvious now you point it out! :oops:

Cheers

Dave
by djeyewater
2013-09-07T04:53:28-07:00
Forum: Users
Topic: thumbnail file size
Replies: 3
Views: 2704

thumbnail file size

With ImageMagick 6.5.9 when I resize an image to 500 pixels on the longest side and then resize this to a 150 pixels on the longest side thumbnail, the thumbnail has a much smaller file size than just resizing straight to a thumbnail without the intermediate 500px version. For my test file I get a t...
by djeyewater
2013-09-01T12:44:20-07:00
Forum: Users
Topic: Overlay SVG image onto JPEG (watermark)
Replies: 3
Views: 5212

Re: Overlay SVG image onto JPEG (watermark)

Thanks for the suggestions, after adding -background none I was still having an issue with opacity of the SVG shape being 100% rather than the 50% set in the SVG. I did some searching and found that rather than setting opacity on the <g> containing the shape path, fill-opacity="0.5" should be set on...
by djeyewater
2013-08-30T02:04:19-07:00
Forum: Users
Topic: Overlay SVG image onto JPEG (watermark)
Replies: 3
Views: 5212

Overlay SVG image onto JPEG (watermark)

I would like to overlay an SVG image on top of a raster image so that the SVG image's width is 20% of the raster image's width and is placed 10% in from the bottom left edge of the image. I've tried the following command, but it doesn't seem to affect the size or offset of the SVG at all, plus the S...
by djeyewater
2012-01-30T15:19:58-07:00
Forum: Bugs
Topic: ImageMagick crashing randomly on Windows
Replies: 12
Views: 26661

Re: ImageMagick crashing randomly on Windows

No, I'm afraid not. Sometimes the batch script will loop through and process all the images successfully, while other times it will crash quite a few times. Hopefully LordOfTheStrings is still monitoring this thread since he/she said they had some images that always cause a crash.
by djeyewater
2012-01-30T13:20:45-07:00
Forum: Bugs
Topic: ImageMagick crashing randomly on Windows
Replies: 12
Views: 26661

Re: ImageMagick crashing randomly on Windows

No, unfortunately it still crashes when adding -define tiff:exif-properties=false to the command. I tried with JPEGs and they work fine, just seems to be these TIFFs. Maybe some non-standard tag added to TIFFs by Photoshop. I tried using ImageMagick to strip the exif from the TIFFs, but it crashes. ...
by djeyewater
2012-01-30T04:01:13-07:00
Forum: Bugs
Topic: ImageMagick crashing randomly on Windows
Replies: 12
Views: 26661

Re: ImageMagick crashing randomly on Windows

Just tried the latest version ImageMagick-6.7.5-0-Q16-windows-x64-dll.exe but it is still crashing randomly for me.
by djeyewater
2012-01-24T14:46:57-07:00
Forum: Bugs
Topic: ImageMagick crashing randomly on Windows
Replies: 12
Views: 26661

ImageMagick crashing randomly on Windows

I'm on Windows 7 and have installed ImageMagick-6.7.4-8-Q16-windows-x64-dll.exe I'm running a batch script that loops through a folder of images, and calls ImageMagick to crop them. However, sometimes ImageMagick crashes and I get an error message "ImageMagick Studio library and utility programs has...
by djeyewater
2010-01-22T15:51:14-07:00
Forum: Users
Topic: When to use -colorspace
Replies: 3
Views: 6633

Re: When to use -colorspace

I am no expert on profiles, but I don't think using them both at the same time is appropriate. see http://www.imagemagick.org/Usage/formats/#color_profile Thanks for the link, unfortunately there doesn't seem to be much info on whether you should -colorspace as well as -profile there, all it says a...
by djeyewater
2010-01-22T12:30:51-07:00
Forum: Users
Topic: When to use -colorspace
Replies: 3
Views: 6633

When to use -colorspace

I need to convert images to sRGB, so I'm using convert with -profile. But I see there is also a -colorspace option. Should I use -colorspace sRGB as well as -profile /path/to/sRGB.icc?

Thanks

Dave
by djeyewater
2009-08-20T07:49:06-07:00
Forum: Bugs
Topic: XMP being lost/corrupted on conversion
Replies: 6
Views: 15681

Re: XMP being lost/corrupted on conversion

Any updates on this would be greatly appreciated. I just tried my problem file in 6.5.4-10, and the XMP (and exif) could be read in FF exif viewer, Opanda Iexif FF plugin (in windows), the File Info Panel in Adobe Photoshop, and also the metadata panel in Adobe Bridge. However, when I tried writing...
by djeyewater
2009-07-29T04:28:38-07:00
Forum: Bugs
Topic: XMP being lost/corrupted on conversion
Replies: 6
Views: 15681

Re: XMP being lost/corrupted on conversion

That's quick!

Just wanted to make sure you realise that my analysis that the problem was due to a space between 'http://ns.adobe.com/xap/1.0/' and '.<?xpacket', was only a guess (and probably wrong I expect).

Thanks for the work you put into this program.

Regards

Dave
by djeyewater
2009-07-26T15:26:53-07:00
Forum: Bugs
Topic: XMP being lost/corrupted on conversion
Replies: 6
Views: 15681

Re: XMP being lost/corrupted on conversion

Thanks for the quick reply. I have done some more testing with exiftool, and it seems that while it can read the exif on the converted file, it can't write to it: exiftool -v3 -a -n -EXIF:ExposureProgram=3 -o "-testRewriteExif.jpg" "-test.jpg" > "-testRewriteExif.jpgExiftool" Outputs Writing ExifIFD...
by djeyewater
2009-07-25T09:51:38-07:00
Forum: Bugs
Topic: XMP being lost/corrupted on conversion
Replies: 6
Views: 15681

XMP being lost/corrupted on conversion

I'm using ImageMagick-6.5.4-5 on Ubuntu 9.04. Build is from source, without-perl. When I convert a JPEG image with XMP metadata embedded, the XMP seems to get lost or corrupted. Viewing the exif of the converted image using the Exif Viewer v1.45 plugin for Firefox, it gives the following output: Han...