Search found 23 matches

by areohbee
2014-09-06T21:17:04-07:00
Forum: Users
Topic: jpeg2000 color/tone is off
Replies: 9
Views: 4728

Re: jpeg2000 color/tone is off

Thanks. jpeg2000 does need icc-profile for proper color/tone - I think you nailed it..
by areohbee
2014-09-06T20:28:57-07:00
Forum: Users
Topic: jpeg2000 color/tone is off
Replies: 9
Views: 4728

Re: jpeg2000 color/tone is off

AdobeRGB, and yes: profile was present.

Bear with me and I'll try latest version, and if still no go provide some more info and sample files.

PS: -format syntax was used to cue Lightroom plugin what the output extension was (uses lua pattern matching).

R
by areohbee
2014-09-06T20:05:52-07:00
Forum: Users
Topic: jpeg2000 color/tone is off
Replies: 9
Views: 4728

Re: jpeg2000 color/tone is off

Thank you for the time you've invested so far to answer. Unfortunately, I am too busy to pursue right now. Whether you (or anybody else) can or can't reproduce using the latest version (or whatever version you have, on your platform, your command, your images..) - that would be good to know. Exact c...
by areohbee
2014-09-06T19:50:34-07:00
Forum: Users
Topic: jpeg2000 color/tone is off
Replies: 9
Views: 4728

Re: jpeg2000 color/tone is off

a question such as yours provides no useful information Just wanted to offer a heads up that jp2 conversion may have color/tone issues. If you can't reproduce, but you still want to pursue, I will provide more info than this: * Platform: Windows 7 * IM version: 6.7.3-Q16 (I am not using the latest ...
by areohbee
2014-09-06T18:26:40-07:00
Forum: Users
Topic: jpeg2000 color/tone is off
Replies: 9
Views: 4728

jpeg2000 color/tone is off

I was hoping to support conversion to jp2 via image-magick command-line, however color and tone is off (like how things look when icc-profile is wrong..).

Note: I assessed color/tone by comparing source tiff against jp2 in ACDSee and Photoshop.

Any ideas/clues?...
by areohbee
2014-05-23T21:03:55-07:00
Forum: Bugs
Topic: adaptive-sharpen not working?
Replies: 33
Views: 46474

Re: adaptive-sharpen not working?

Did you try my files? (posted above).

Also, I tried exporting from Lightroom with high output sharpening, to assure there was something for the algorithm to bite on - still no possibility for adaptive sharpening at 1000 pixels long edge - I tried sigmas between 2 and 50.
by areohbee
2014-05-23T19:56:24-07:00
Forum: Bugs
Topic: adaptive-sharpen not working?
Replies: 33
Views: 46474

Re: adaptive-sharpen not working?

More info: I found if I shrink my images more, the adaptive sharpening becomes effective. For example: 300 long edge - strong edge-sharpening effect, amount depends on sigma - as it should.. 1000 long edge - no adaptive sharpening, at any sigma. Note: if I crank up the radius, it takes a long time, ...
by areohbee
2014-05-23T19:37:42-07:00
Forum: Bugs
Topic: adaptive-sharpen not working?
Replies: 33
Views: 46474

Re: adaptive-sharpen not working?

Works perfectly on lena, but not my jpegs. Here is a demo file - it's a zip with original jpeg, converted jpegs, commands issued to create the conversions. http://www.robcole.com/ImageMagickForum/01%20Wild%20Turkeyard.zip Note: conversions differ ( unnoticeably ) from original, but each conversion i...
by areohbee
2014-05-23T17:47:22-07:00
Forum: Bugs
Topic: adaptive-sharpen not working?
Replies: 33
Views: 46474

Re: adaptive-sharpen not working?

Does anybody have any clue as to why adaptive sharpening is NOT working, for me ? I mean, I'm happy that that it works for some folks, but my objective in posting is 2-fold: * Raise the possibility of a bug. * If no bug, determine why I can't get it to do anything. Am I the only one having this prob...
by areohbee
2014-05-23T05:12:36-07:00
Forum: Bugs
Topic: adaptive-sharpen not working?
Replies: 33
Views: 46474

Re: adaptive-sharpen not working?

Just tried latest version 6.8.9 (windows binary) and I still can't get adaptive sharpen to do anything, no matter what I try, e.g. -adaptive-sharpen 0x0.6 nothing -adaptive-sharpen 6x2 nothing Am I doing something wrong or is it still broken? note: regular sharpening works fine, e.g. -sharpen 0x.6
by areohbee
2013-08-11T23:44:07-07:00
Forum: Users
Topic: Question: is rotating by 90, 180, 270 destructive
Replies: 10
Views: 11646

Re: Question: is rotating by 90, 180, 270 destructive

Try -copy all to keep profiles, etc.
There we go - thanks GreenKoopa.

And thanks to everyone - you've been most helpful.

PS - I'm using IM v6.7.3 - 16 bits (win7/64) now, but I may upgrade soon if icc difficulties are all sorted out.

Cheers,
Rob
by areohbee
2013-08-11T20:55:44-07:00
Forum: Users
Topic: Question: is rotating by 90, 180, 270 destructive
Replies: 10
Views: 11646

Re: Question: is rotating by 90, 180, 270 destructive

Thanks again snibgo.

I am using the latest version of jpegtran (Windows .exe) and it seems to rotate OK, I think (?), but loses the icc profile in the process :( .

ICC profiles seem to be particularly problematic for many softwares, still, even in this supposedly modern age :o .

Cheers,
Rob
by areohbee
2013-08-11T18:38:35-07:00
Forum: Users
Topic: Question: is rotating by 90, 180, 270 destructive
Replies: 10
Views: 11646

Re: Question: is rotating by 90, 180, 270 destructive

Awesome - thanks! (and I dunno why I didn't think to do the 4 rotation test - good thinking :D ).
by areohbee
2013-08-11T18:16:43-07:00
Forum: Users
Topic: Question: is rotating by 90, 180, 270 destructive
Replies: 10
Views: 11646

Re: Question: is rotating by 90, 180, 270 destructive

Subject format: jpeg. So, if I understood you correctly, Image Magick will "re-jpeg the jpeg" when rotating by say 90 degrees, rather than "transposing" the data losslessly. i.e. it is not a "specialized tool" as per your definition. Is that correct? If so, do you know of such a specialized tool for...
by areohbee
2013-08-11T18:09:13-07:00
Forum: Bugs
Topic: adaptive-sharpen not working?
Replies: 33
Views: 46474

Re: adaptive-sharpen not working?

There is thread dedicated to the ICC profile problem - apparently it has been fixed now (I haven't verified fix), ref:

viewtopic.php?f=3&t=16699