Search found 14 matches

by gregaiken
2015-04-24T07:20:27-07:00
Forum: Users
Topic: -function Polynomial 0.123(how many places supported?)456
Replies: 8
Views: 4828

Re: -function Polynomial 0.123(how many places supported?)456

i am just reporting that this proved to be the problem! once i recalculated my coefficients to work with pixel values having a range of 0 to 1, then plugged those new coefficients into the convert function, things worked perfectly! so imagemagick had no trouble using all of those digits to the right...
by gregaiken
2015-04-23T15:52:28-07:00
Forum: Users
Topic: -function Polynomial 0.123(how many places supported?)456
Replies: 8
Views: 4828

Re: -function Polynomial 0.123(how many places supported?)456

Thank you SO MUCH snibgo !

I imagined this was most probably somehow my fault. I did not realize the pixel values needed to be rescaled to be in between 0 and 1.

ill go back to the drawing board and try this again.

again thanks for the suggestion.
by gregaiken
2015-04-23T15:20:38-07:00
Forum: Users
Topic: -function Polynomial 0.123(how many places supported?)456
Replies: 8
Views: 4828

Re: -function Polynomial 0.123(how many places supported?)456

ive posted a clear to follow step-by-step procedure of how i came to derive the required coefficients, and the exact command i ran, as well as providing a link to the sample image (these coefficients were designed for). the document is a bit long, and includes a number of embedded images, so ive pos...
by gregaiken
2015-04-22T12:16:37-07:00
Forum: Users
Topic: -function Polynomial 0.123(how many places supported?)456
Replies: 8
Views: 4828

-function Polynomial 0.123(how many places supported?)456

i am having trouble using the convert in.jpg -function Polynomial 0.123(how many digits are actually supported by convert?)325,0.1234567890123456789012325,0.12345678901234567890123250.1234567890123456789012325 out.jpg function. the example above shows arbitrary polynomial coefficients. the convert f...
by gregaiken
2014-04-10T16:33:05-07:00
Forum: Bugs
Topic: '-distort Perspective' doesnt seem to work properly
Replies: 3
Views: 5085

Re: '-distort Perspective' doesnt seem to work properly

it seems i did mistakenly enter wrong coordinates. once i specified the proper coordinates - it worked as expected. my sincere apologies for wasting bandwidth here... "C:\Program Files (x86)\ImageMagick-6.8.6-Q16\convert.exe" in.png -verbose -distort Perspective "250.5,250.5,500.5,500.5 2249.5,250.5...
by gregaiken
2014-04-10T15:52:32-07:00
Forum: Bugs
Topic: '-distort Perspective' doesnt seem to work properly
Replies: 3
Views: 5085

Re: '-distort Perspective' doesnt seem to work properly

actually, the reference points ive used are the four corners of my 'black and white grid' upper-left corner of 'black and white' grid (250,250) upper-right corner of 'black and white' grid (2449,250) lower-left corner of 'black and white grid' (250,2449) lower-right corner of 'black and white grid' ...
by gregaiken
2014-04-10T14:35:44-07:00
Forum: Bugs
Topic: '-distort Perspective' doesnt seem to work properly
Replies: 3
Views: 5085

'-distort Perspective' doesnt seem to work properly

In the example I did (using IM 6.8.6-Q16), i intentionally kept the lower-left and lower-right 'corners' of my image IDENTICAL (eg; specified to NOT shift), and i intentionally shifted the upper-left and upper-right 'corners' of my image. ImageMagick did do the distort, but in my opinion - it did so...
by gregaiken
2014-04-02T10:09:18-07:00
Forum: PerlMagick
Topic: [PerlMagick] SetPixel not properly setting RGB value
Replies: 4
Views: 25818

Re: [PerlMagick] SetPixel not properly setting RGB value

i am using a newer version if ImageMagick 6.8.6-Q16 Windows x86 build - and this same problem persists. ive been hoping for a long while to finally get to use ImageMagick with ActivePerl. i finally have this configured and am rather unhappy to discover i also can not reliably set pixel values within...
by gregaiken
2012-03-21T16:09:25-07:00
Forum: Users
Topic: offer to get imagemagick-6.7.1 built for Windows sp1
Replies: 3
Views: 7111

Re: offer to get imagemagick-6.7.1 built for Windows sp1

the explanation is very much appreciated. but from what ive read its more than daunting for someone unfamiliar with c++ to as a first time introduction, compile the glorious 'imagemagick' with all of its required libraries. if anyone can point me to a 'step by step' 'how to build imagemagick for win...
by gregaiken
2012-03-21T15:11:51-07:00
Forum: Users
Topic: offer to get imagemagick-6.7.1 built for Windows sp1
Replies: 3
Views: 7111

offer to get imagemagick-6.7.1 built for Windows sp1

I was wondering if any imagemagick developer might be able and willing to compile imagemagick6.7.1 to install and run on WindowsXP service pack 1. built in a manner where it has full 'delegate' support to integrate with 'Ghostscript', 'ffmpeg', and other image delegates that i already have installed...
by gregaiken
2012-03-21T15:05:21-07:00
Forum: Users
Topic: desire CIELab space in imagemagick
Replies: 1
Views: 4319

desire CIELab space in imagemagick

is there a way to convert an RGB image file to either: a. a CIELab color space (PDF supports such a native color space, as does OpenExr), or b. to a CIELab raw ASCII format? can any one provide a sample one-liner that would demonstrate this usage? the reason being i need to convert an RGB image file...
by gregaiken
2011-08-21T13:18:45-07:00
Forum: Users
Topic: Does Imagemagick 6710 install & run on XP sp 1?
Replies: 2
Views: 5631

Re: Does Imagemagick 6710 install & run on XP sp 1?

to add more information here...

actually the computer is XP sp1

though ive made a few changes in the registry so that it reports sp2.

true fact is that ive not run the XP sp2 upgrade on that computer.

so technically, imagemagick 6.7.1 was installed to an XP sp1 computer.
by gregaiken
2011-08-21T12:13:30-07:00
Forum: Users
Topic: Does Imagemagick 6710 install & run on XP sp 1?
Replies: 2
Views: 5631

Re: Does Imagemagick 6710 install & run on XP sp 1?

The official docs say ImageMagick 6.7.1 requires XP sp3.
This is not true.
I just installed it to XP sp2.

Just wanted anyone who cares to know this...
by gregaiken
2011-07-21T16:41:14-07:00
Forum: Users
Topic: Does Imagemagick 6710 install & run on XP sp 1?
Replies: 2
Views: 5631

Does Imagemagick 6710 install & run on XP sp 1?

The requirements page states clearly that Imagemagick 6.7.1.0 REQUIRES Windows XP Service Pack 3. Lots of software developers make this statement - yet it proves NOT to be a hard requirement. I have a happily running older version of Imagemagick on my Windows XP sp 1 computer, and I am hesitant to t...