Search found 7 matches

by REPTILE
2014-01-03T13:39:31-07:00
Forum: Magick++
Topic: Problems using magick++
Replies: 12
Views: 16823

Re: Problems using magick++

thanks for your help, i have post a topic on the provided link.... something with dpx images is not working.....
by REPTILE
2014-01-03T11:07:23-07:00
Forum: Magick++
Topic: Problems using magick++
Replies: 12
Views: 16823

Re: Problems using magick++

TIF, and TIF supports 12bit

with the command line tool "convert" this works with "-depth 12"
by REPTILE
2014-01-03T10:03:02-07:00
Forum: Magick++
Topic: Problems using magick++
Replies: 12
Views: 16823

Re: Problems using magick++

dlemstra wrote:You can use the Depth property of MagickImage to change the color depth.
mhh, this result in the same color depth, when i load a 8 bit picture, the output picture is also 8bit

Code: Select all

Using image As New MagickImage(input)
            image.BitDepth(12)
            image.Write(output)
        End Using
by REPTILE
2014-01-03T09:05:45-07:00
Forum: Magick++
Topic: Problems using magick++
Replies: 12
Views: 16823

Re: Problems using magick++

Yes i did, but without success... at the moment i give up :), now i use magick.net in my vb.net main program. This works fine :) Do you know how i convert the color depth of a picture.... ? .SetAttribute("depth", 12) only sets the attribut for this but this result in false colors... i want to conver...
by REPTILE
2014-01-02T10:12:07-07:00
Forum: Magick++
Topic: Problems using magick++
Replies: 12
Views: 16823

Re: Problems using magick++

hi, now i have start from scratch, delete all projekt files, unzip the "imagemagick-windows.zip", run the configure program and build magick++ without any config change.... this was done without errors... So, now build my testprogramm and now i have a different error at runtime.... Unhandled excepti...
by REPTILE
2013-12-31T09:08:11-07:00
Forum: Magick++
Topic: Problems using magick++
Replies: 12
Views: 16823

Re: Problems using magick++

Yes it seems to be, strange content of the "fileName_" char, but i tested some settings any change....
I have set the "Charset" (Config/common settings) to Unicode-Charset on both projects (magick++ and my project), or exist somethings else to change the charset?
by REPTILE
2013-12-30T10:14:02-07:00
Forum: Magick++
Topic: Problems using magick++
Replies: 12
Views: 16823

Problems using magick++

Hello, i am try to use magick++ for my vc++.net projects.... I use Visual Studio 2013 i have successfully compiled the magick++ libs and dlls.... now i have write a small progamm to test the function of the magick++ #include "stdafx.h" #include <cstdio> #include <iostream> #include <string.h> #inclu...