Search found 17 matches

by mortoray
2014-04-13T21:00:45-07:00
Forum: Bugs
Topic: Sepia filter doesn't handle alpha channel (corrupt output)
Replies: 12
Views: 17733

Re: Sepia filter doesn't handle alpha channel (corrupt outpu

Any update on this defect?
by mortoray
2014-04-04T01:30:43-07:00
Forum: Kudos and Rants
Topic: I know they're there...but who the heck is using ImageMagick
Replies: 8
Views: 34035

Re: I know they're there...but who the heck is using ImageMa

Our new service http://redid.net/ depends heavily on ImageMagick. We're using it to provide on-demand image transformations to simplify web development.
by mortoray
2014-04-04T00:12:43-07:00
Forum: Bugs
Topic: Sepia filter doesn't handle alpha channel (corrupt output)
Replies: 12
Views: 17733

Defect in fx.c found

I believe I found the problem. On fx.c:4122 clone image is called with an explicit width/height, meaning the source pixels are not copied: sepia_image=CloneImage(image,image->columns,image->rows,MagickTrue,exception); The problem is that the alpha channel is never set in the remainder of the functio...
by mortoray
2014-04-03T23:09:49-07:00
Forum: Bugs
Topic: Sepia filter doesn't handle alpha channel (corrupt output)
Replies: 12
Views: 17733

Re: Corrupt output image wit sepia and WEBP

The same thing also happens on the version of IM in Ubuntu 12.04. So it's not likely something I configured wrong.
by mortoray
2014-04-03T22:28:37-07:00
Forum: Bugs
Topic: Sepia filter doesn't handle alpha channel (corrupt output)
Replies: 12
Views: 17733

Re: Corrupt output image wit sepia and WEBP

I'm running webp 0.4.0 (downloaded the newest a few days ago). But as I mentioned, it isn't limited to webp. I'm seeing the problem with PNG files as well.

The two thread limit options didn't change the result.
by mortoray
2014-04-03T22:13:02-07:00
Forum: Bugs
Topic: Sepia filter doesn't handle alpha channel (corrupt output)
Replies: 12
Views: 17733

Re: Corrupt output image wit sepia and WEBP

How do I disable OpenMP?

Note this only seems to happen with the sepia filter. I've not seen the problem with any other transformation yet. And it appears consistent now, any transparent input into the sepia filter causes this issue.
by mortoray
2014-04-02T23:49:03-07:00
Forum: Bugs
Topic: Sepia filter doesn't handle alpha channel (corrupt output)
Replies: 12
Views: 17733

Re: Corrupt output image wit sepia and WEBP

It appears this can happen with any combination of an alpha input, the sepia filter, and alpha output.
by mortoray
2014-04-02T23:43:21-07:00
Forum: Bugs
Topic: Sepia filter doesn't handle alpha channel (corrupt output)
Replies: 12
Views: 17733

Re: Corrupt output image wit sepia and WEBP

Version info: Version: ImageMagick 6.8.8-10 Q16 x86_64 2014-04-01 http://www.imagemagick.org Copyright: Copyright (C) 1999-2014 ImageMagick Studio LLC Features: DPC OpenMP Delegates: bzlib djvu fontconfig freetype jng jpeg lcms lqr openexr pangocairo png tiff webp x xml zlib WebP Version 0.4.0 gcc (...
by mortoray
2014-04-02T23:41:34-07:00
Forum: Bugs
Topic: Sepia filter doesn't handle alpha channel (corrupt output)
Replies: 12
Views: 17733

Sepia filter doesn't handle alpha channel (corrupt output)

I hit a situation where the generated image is corrupt. It happens when I resize a WEBP image and apply a sepia filter. If I don't resize, or I don't apply a filter, or I apply a different filter, it doesn't happen. convert tux.webp -resize 190 -sepia-tone 50% out.png Below is the input image. Sorry...
by mortoray
2014-04-01T01:43:15-07:00
Forum: Users
Topic: How to output a lossless webp image?
Replies: 1
Views: 5270

How to output a lossless webp image?

How can I tell `convert` that I want a lossless WEBP file as output? It looks like it always uses lossy mode.
by mortoray
2014-03-31T23:18:25-07:00
Forum: Bugs
Topic: Identify is failing on a JPEG file (worked before)
Replies: 6
Views: 9136

Re: Identify is failing on a JPEG file (worked before)

Installing lcms2 makes the problem go away.
by mortoray
2014-03-31T10:46:29-07:00
Forum: Bugs
Topic: Identify is failing on a JPEG file (worked before)
Replies: 6
Views: 9136

Re: Identify is failing on a JPEG file (worked before)

My system is using liblcms.so.1
by mortoray
2014-03-31T09:26:03-07:00
Forum: Bugs
Topic: Identify is failing on a JPEG file (worked before)
Replies: 6
Views: 9136

Re: Identify is failing on a JPEG file (worked before)

I'm using Ubuntu 12.04 LTS. Also libjpeg.so.8. List format also shows the same version. But I don't the issue is with decoding, since the error occurs strictly with identify: convert is able to load the file. I think "lcms" is the library responsible for the color profiles, so perhaps the problem is...
by mortoray
2014-03-31T02:23:12-07:00
Forum: Bugs
Topic: Identify is failing on a JPEG file (worked before)
Replies: 6
Views: 9136

Identify is failing on a JPEG file (worked before)

I have a JPEG file (below) that `identify` is no longer able to process. It fails with the error "lcms: Error #12288; Pointer error; probably corrupted file". Strangely `convert` doesn't have a problem with the file. Nor did `identify` from a previous IM version "6.6.9-7". Version: ImageMagick 6.8.8...
by mortoray
2014-02-13T01:27:28-07:00
Forum: Users
Topic: Subtract opaque region of one image from another
Replies: 4
Views: 2970

Re: Subtract opaque region of one image from another

I understand now clearly. Thank you.