Search found 10 matches

by goldfish
2016-10-13T07:50:33-07:00
Forum: Bugs
Topic: DLL Problems in 64-Bit Windows v7.0.1-x Distributions
Replies: 10
Views: 8224

Re: DLL Problems in 64-Bit Windows v7.0.1-x Distributions

dlemstra wrote:Can you give it a try with the latest installer? I haven't had time to test it myself but you should now be able to use PerlMagick again.
Definitely! I will give it a shot a little later today.
by goldfish
2016-10-03T20:45:43-07:00
Forum: Bugs
Topic: DLL Problems in 64-Bit Windows v7.0.1-x Distributions
Replies: 10
Views: 8224

Re: DLL Problems in 64-Bit Windows v7.0.1-x Distributions

The dll that is created looks incorrect. For some reason it is creating an executable instead of a dll. I will have to investigate what is happening on AppVeyor to figure out why it breaks. EDIT: I figured out why it breaks. Not sure how to fix it yet though :) Hey, that's a big step in the right d...
by goldfish
2016-10-03T09:31:44-07:00
Forum: Bugs
Topic: DLL Problems in 64-Bit Windows v7.0.1-x Distributions
Replies: 10
Views: 8224

Re: DLL Problems in 64-Bit Windows v7.0.1-x Distributions

C:\Strawberry\perl\site\lib\auto\Image\Magick\Magick.xs.dll is either not designed to run on Windows or it contains an error. Try installing the program again using the original media or contact your system administrator or software vendor for support I get the same error (Win7 64, Strawberry Perl ...
by goldfish
2016-06-14T08:09:26-07:00
Forum: Bugs
Topic: DLL Problems in 64-Bit Windows v7.0.1-x Distributions
Replies: 10
Views: 8224

Re: DLL Problems in 64-Bit Windows v7.0.1-x Distributions

I tried the 7.0.2-0 distribution today, and I'm still getting the same error. Has anyone been able to run PerlMagick on a 64-bit Windows machine with IM v7?
by goldfish
2016-06-04T21:08:03-07:00
Forum: Bugs
Topic: DLL Problems in 64-Bit Windows v7.0.1-x Distributions
Replies: 10
Views: 8224

Re: DLL Problems in 64-Bit Windows v7.0.1-x Distributions

Yup yup -- the Perl version is the same now as it was when all my scripts worked, which was when they ran off the DLLs from ImageMagick v6.9.3. I unfortunately cannot roll back to the version that worked because of the exploit which v7+ fixed. The version is Strawberry Perl v5.20.2 for 64-bit Window...
by goldfish
2016-06-04T13:59:54-07:00
Forum: Bugs
Topic: DLL Problems in 64-Bit Windows v7.0.1-x Distributions
Replies: 10
Views: 8224

DLL Problems in 64-Bit Windows v7.0.1-x Distributions

Hello All, I posted this question to the PerlMagick forum , and thought I would try my luck here. I'm not sure if this is a bug, but Windows and Perl are complaining about the DLLs that come with the Windows distributions. I'm running Perl v5.20.2 built for MSWin32-x64-multi-thread on a 64-bit Windo...
by goldfish
2016-06-02T12:26:41-07:00
Forum: PerlMagick
Topic: Unable to Execute Script after Installing ImageMagick v7.0.1
Replies: 7
Views: 19612

Re: Unable to Execute Script after Installing ImageMagick v7.0.1

is it possible you are trying to load a 32-bit Imagemagick on 64-bit machine You know, that's definitely possible. It could also be that this DLL is designed for Linux, Mac, or something else. I'm unfortunately not too great with DLLs, and I wouldn't be surprised if the fault lies with me or my env...
by goldfish
2016-05-31T17:33:40-07:00
Forum: PerlMagick
Topic: Unable to Execute Script after Installing ImageMagick v7.0.1
Replies: 7
Views: 19612

Re: Unable to Execute Script after Installing ImageMagick v7.0.1

My apologies, the convert issue is a red herring. The real problem is Magick.xs.dll is being reported as "either not designed to run on Windows or it contains an error". That message pops up as soon as the Image::Magick module is loaded: C:\Users\Documents>perl -e "use Image::Magick" Can't load 'C:/...
by goldfish
2016-05-31T13:30:11-07:00
Forum: PerlMagick
Topic: Unable to Execute Script after Installing ImageMagick v7.0.1
Replies: 7
Views: 19612

Re: Unable to Execute Script after Installing ImageMagick v7.0.1

Thank you for the reply. From what the error messages are telling me, it looks like the DLL that comes with this 7.0.1 release (Magick.xs.dll) is not working with Windows, though I don't know why. Also, forgive my ignorance... I'm a bit lost in general with this upgrade. If convert.exe and the like ...
by goldfish
2016-05-29T20:38:24-07:00
Forum: PerlMagick
Topic: Unable to Execute Script after Installing ImageMagick v7.0.1
Replies: 7
Views: 19612

Unable to Execute Script after Installing ImageMagick v7.0.1

Hi all, I'm running Perl v5.20.2 built for MSWin32-x64-multi-thread on a 64-bit Windows Server 2008 R2 Enterprise machine. I had been using PerlMagick installed with the DLLs that came with ImageMagick v6.9.3 without issue, but I can't get the same script to work with the DLLs from v7.0.1 . After fu...