Search found 5 matches

by Mr1Penguin
2016-11-22T15:29:58-07:00
Forum: Developers
Topic: OpenCL no effect?
Replies: 6
Views: 6741

Re: OpenCL no effect?

I changed a code a little so it works for me now. But it requires image with alpha channel to work. I'll try to find workaround for that(maybe converting to png with alpha if image does not have it)
---Added---
And now it works with images without alpha
by Mr1Penguin
2016-11-21T05:52:54-07:00
Forum: Developers
Topic: OpenCL no effect?
Replies: 6
Views: 6741

Re: OpenCL no effect?

Hm. Found AccelerateMotionBlurImage function in accelerate.c/accelerate-private.h. And no one call it. Checked AccelerateBlurImage function and found call from effects.c. I'll try to call it from motion-blur function and give answer. ----added---- Looks like i can't do it right now and AccelerateMot...
by Mr1Penguin
2016-11-21T05:35:41-07:00
Forum: Developers
Topic: OpenCL no effect?
Replies: 6
Views: 6741

Re: OpenCL no effect?

PS C:\Users\igors\Downloads\abc> Measure-Command {magick art.jpg -resize 4096x4096! -blur 40x40 `( art.jpg `( -clone 0 -background black -shadow 60x25+0+0 `) -reverse -background none -layers merge +repage `) -gravity center -composite out.jpg} opencl: 3113ms openmp: 16263ms Looks like opencl reall...
by Mr1Penguin
2016-11-21T04:54:55-07:00
Forum: Developers
Topic: OpenCL no effect?
Replies: 6
Views: 6741

Re: OpenCL no effect?

According this link opencl used in motion-blur too.
http://www.imagemagick.org/script/opencl.php
by Mr1Penguin
2016-11-21T04:27:31-07:00
Forum: Developers
Topic: OpenCL no effect?
Replies: 6
Views: 6741

OpenCL no effect?

Hi! I compiled imagemagick on windows. Trying to process 800x450 image. I have suggestion imagemagick uses my cpu instead of gpu for making blur. Does it normal behavior? only openmp: PS C:\Users\igors\Downloads\abc> Measure-Command {magick a.jpg -resize 800x800! -blur 20x20 -motion-blur 0x80-90 -mo...