Search found 8 matches

by ojensen5115
2018-04-08T19:12:48-07:00
Forum: Users
Topic: [Solved] Black pixel artifacts after "modulate" in 6.9.7-4
Replies: 6
Views: 3552

Re: Black pixel artifacts after "modulate" in 6.9.7-4

For anyone else who ends up finding this post, while waiting for the "proper" fix to hit the repos I have discovered that the following workaround works very well, without messing up the colors: resize image up to 140% size modulate image to reduce contrast by 75% and reduce lightness by 3% modulate...
by ojensen5115
2018-04-08T13:28:27-07:00
Forum: IMagick
Topic: How to "swap out" underlying ImageMagick version?
Replies: 4
Views: 7638

Re: How to "swap out" underlying ImageMagick version?

I am aware (hence posting in the IMagick sub-forum rather than one of the ImageMagick ones) and figured it was a long shot. Still, thank you for your help, I appreciate the guidance you sent my way :)
by ojensen5115
2018-04-08T09:17:20-07:00
Forum: IMagick
Topic: How to "swap out" underlying ImageMagick version?
Replies: 4
Views: 7638

Re: How to "swap out" underlying ImageMagick version?

Thanks, I'll give that a try. Hopefully not too much has changed between 6.9.7-4 and 6.9.9-41. I'm having some trouble getting it set up -- I installed 6.9.9-41 via checkinstall and restarted Apache, but phpinfo still shows 6.9.7-4 to be in use. Removing the old version of imagemagick via apt (this ...
by ojensen5115
2018-04-07T22:06:02-07:00
Forum: IMagick
Topic: How to "swap out" underlying ImageMagick version?
Replies: 4
Views: 7638

How to "swap out" underlying ImageMagick version?

Currently I have the following configuration set up: imagick module version: 3.4.3RC2 imagick classes: Imagick, ImagickDraw, ImagickPixel, ImagickPixelIterator, ImagickKernel Imagick compiled with ImageMagick version: ImageMagick 6.9.7-4 Q16 x86_64 20170114 http://www.imagemagick.org Imagick using I...
by ojensen5115
2018-03-27T14:08:50-07:00
Forum: Users
Topic: [Solved] Black pixel artifacts after "modulate" in 6.9.7-4
Replies: 6
Views: 3552

Re: Black pixel artifacts after "modulate" in 6.9.7-4

Yes, the image is already sRGB. To get "modulate" to work correctly, I have to first convert it from sRGB to RGB, then perform the hue shift on the RGB image, then convert it back from RGB to sRGB (since the rest of my process assumes sRGB). Thank you for reporting the bug! EDIT: interestingly, with...
by ojensen5115
2018-03-26T23:37:16-07:00
Forum: Users
Topic: [Solved] Black pixel artifacts after "modulate" in 6.9.7-4
Replies: 6
Views: 3552

Re: Black pixel artifacts after "modulate" in 6.9.7-4

I note that the black does not appear if I first convert the image to RBG. In general, modulate seems to do rather wonky things with the hue in colorspaces other than SRGB and RGB -- perhaps it is implemented under the assumption that it is working on the RGB colorspace, and the fact that it appears...
by ojensen5115
2018-03-26T22:25:46-07:00
Forum: Users
Topic: [Solved] Black pixel artifacts after "modulate" in 6.9.7-4
Replies: 6
Views: 3552

Re: Black pixel artifacts after "modulate" in 6.9.7-4

Thank you fmw42 for your response. The black dots do not indeed appear when using

Code: Select all

modulate:colorspace=HCL
but then the colors get all wonky:
https://i.imgur.com/zPUD2P4.png
by ojensen5115
2018-03-26T14:59:23-07:00
Forum: Users
Topic: [Solved] Black pixel artifacts after "modulate" in 6.9.7-4
Replies: 6
Views: 3552

[Solved] Black pixel artifacts after "modulate" in 6.9.7-4

Update: Bugfix is in 6.9.9-40 (currently beta) Workaround for while you wait for that to hit the repos is in this post ------------------ I am having the identical problem as discussed in this post: https://www.imagemagick.org/discourse-server/viewtopic.php?f=1&t=29150 I am creating a new thread be...