Search found 30 matches

by gegupta
2013-10-25T13:55:28-07:00
Forum: Users
Topic: Writing Gif takes huge time.
Replies: 7
Views: 3759

Re: Writing Gif takes huge time.

Hi,

Can you try convert/resize just gif image to a gif?

Thanks
Geetanjali
by gegupta
2013-10-25T12:19:03-07:00
Forum: Users
Topic: Writing Gif takes huge time.
Replies: 7
Views: 3759

Writing Gif takes huge time.

Hello, We are trying to convert gif to a gif but bigger images just take huge time(~10-12 sec to write to shared mem). I wanted to confirm if it normal. We have a timeout of 10sec aroud resize for ourc lients but we have fallen into situation where even 10 sec is not enough. Is there any benchmarkin...
by gegupta
2013-03-29T11:02:24-07:00
Forum: Users
Topic: webp not included - failed tests
Replies: 9
Views: 10768

Re: webp not included - failed tests

HI,

I solved the problem by :

Code: Select all

./configure --with-webp LDFLAGS=-L/usr/local/lib CPPFLAGS=-I/usr/local/include
where by web related stuff was.

Thanks for help!
by gegupta
2013-03-28T13:34:31-07:00
Forum: Users
Topic: webp not included - failed tests
Replies: 9
Views: 10768

Re: webp not included - failed tests

I tried the latest version 6.7.4-2 , which i think contains a patch you were talking about. It throws the same error while making : magick/.libs/libMagickCore-6.Q16.so: undefined reference to `WebPInitDecoderConfigInternal' magick/.libs/libMagickCore-6.Q16.so: undefined reference to `WebPDecode' mag...
by gegupta
2013-03-27T10:03:15-07:00
Forum: Users
Topic: webp not included - failed tests
Replies: 9
Views: 10768

Re: webp not included - failed tests

Hi,

Please help!

Thanks
Geetanjali
by gegupta
2013-03-25T15:29:18-07:00
Forum: Users
Topic: webp not included - failed tests
Replies: 9
Views: 10768

Re: webp not included - failed tests

Hi, This solution worked for me in Mac version of the library but threw an error while making on Ubuntu. Here is the error: magick/.libs/libMagickCore-6.Q16.so: undefined reference to `WebPInitDecoderConfigInternal' magick/.libs/libMagickCore-6.Q16.so: undefined reference to `WebPDecode' magick/.lib...
by gegupta
2013-03-23T22:23:53-07:00
Forum: Users
Topic: webp not included - failed tests
Replies: 9
Views: 10768

Re: webp not included - failed tests

I replaced 4 such occurences. Can you confirm?
Now I am able to convert to webp.

Thanks!
by gegupta
2013-03-22T15:54:42-07:00
Forum: Users
Topic: webp not included - failed tests
Replies: 9
Views: 10768

Re: webp not included - failed tests

Yes, I am using https://code.google.com/p/webp/download ... z&can=2&q=
This worked for me with ImageMagick version 6.7.5 but not 6.8.3. Let me know if you need any log related to 6.7.5

Thanks!
by gegupta
2013-03-22T15:24:19-07:00
Forum: Users
Topic: webp not included - failed tests
Replies: 9
Views: 10768

webp not included - failed tests

HI, I am trying to build ImageMagick from source --with-webp ImageMagickVersion : 6.8.3-10 webp version : libwebp-0.2.1.tar.gz OS: Ubuntu 11.10 Tried as simple as ./configure --with-webp Text from config.log: configure:31887: checking for WEBP configure:31889: result: configure:31893: checking webp/...
by gegupta
2010-12-03T17:09:07-07:00
Forum: Users
Topic: Png getting corrupted
Replies: 21
Views: 35786

Re: Png getting corrupted

Again, I don't believe that there is any fault/bug. That 'corruption' is in the original image. You moved to a format with no alpha support without instructing ImageMagick how you wanted that handled. Having an alpha channel gives an image the ability to do transparency. If an image has every pixel...
by gegupta
2010-12-03T15:14:41-07:00
Forum: Users
Topic: Png getting corrupted
Replies: 21
Views: 35786

Re: Png getting corrupted

Yes GreenKoopa mostly it does. But I experimented with few other images they work fine without removing/replacing background. Alpha statistics of one of them is like Alpha: min: 255 (1) max: 255 (1) mean: 255 (1) standard deviation: 0 (0) kurtosis: 0 skewness: 0 I think the individual components als...
by gegupta
2010-12-03T13:39:07-07:00
Forum: Users
Topic: Png getting corrupted
Replies: 21
Views: 35786

Re: Png getting corrupted

I used this
"convert Panasonic-RP-HS200-K-Black-vfr-detail.png -resize 50% x.jpg"

Actually there are couple of variation with different resize parameter I guess. It distorts it, or make whole image gray black or inserts some artifacts ..
by gegupta
2010-12-03T13:18:36-07:00
Forum: Users
Topic: Png getting corrupted
Replies: 21
Views: 35786

Re: Png getting corrupted

GreenKoopa wrote:Is this caused by -resize or the png->jpeg conversion?

Try:
convert in.png -background white -flatten out.jpg

So the above command you gave essentially removes that alpha transparency?

Thanks
by gegupta
2010-12-03T13:15:53-07:00
Forum: Users
Topic: Png getting corrupted
Replies: 21
Views: 35786

Re: Png getting corrupted

Yes it does contain Alpha transparency I am assuming . This is a snapshot of one portion of identify Channel depth: red: 8-bit green: 8-bit blue: 8-bit alpha: 8-bit Channel statistics: Red: min: 0 (0) max: 255 (1) mean: 185.141 (0.726043) standard deviation: 71.9342 (0.282095) kurtosis: -0.572878 sk...
by gegupta
2010-12-03T12:42:09-07:00
Forum: Users
Topic: Png getting corrupted
Replies: 21
Views: 35786

Png getting corrupted

Hello All, Here is the link to an 189X189 png image which gets corrupted if you try to process through IM. Take this image http://origin-media.onecall.com/Image_Products/Panasonic/Panasonic-RP-HS200-K-Black-vfr-detail.png and process(resize and change format to Jpeg) this image using say "convert Pa...