Compiling Problem

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
FF7Cayn

Compiling Problem

Postby FF7Cayn » 2010-02-08T03:39:47-07:00

Hello everyone!

I am trying to compile Imagemagick ImageMagick-6.5.9-3 on my Debian Etch (2.6.18-6-686-bigmem) System but i get the following error:

Code: Select all

magick/.libs/libMagickCore.so: undefined reference to `gzseek64'
magick/.libs/libMagickCore.so: undefined reference to `gztell64'
magick/.libs/libMagickCore.so: undefined reference to `gzopen64'
collect2: ld returned 1 exit status
make[1]: *** [utilities/animate] Error 1
make[1]: Leaving directory `/var/tmp/ImageMagick-6.5.9-3'
make: *** [all] Error 2

I do have the zlib packages installed.
zlibig - 1:1.2.3 - 13

configure tells me this:

Code: Select all

-------------------------------------------------------------
checking for ZLIB...
checking zconf.h usability... yes
checking zconf.h presence... yes
checking for zconf.h... yes
checking zlib.h usability... yes
checking zlib.h presence... yes
checking for zlib.h... yes
checking for compress in -lz... yes
checking for uncompress in -lz... yes
checking for deflate in -lz... yes
checking for inflate in -lz... yes
checking for gzseek in -lz... yes
checking for gztell in -lz... yes
checking if ZLIB package is complete... yes


I am totally lost what to do else.
ldconfig also shows me that zlib is beeing found.

Any ideas?

User avatar
magick
Site Admin
Posts: 9708
Joined: 2003-05-31T11:32:55-07:00
Contact:

Re: Compiling Problem

Postby magick » 2010-02-08T05:46:55-07:00

You may the i586 version of the zlib delegate library installed. You may need to install the 64-bit version of zlib and zlib-devel.

FF7Cayn

Re: Compiling Problem

Postby FF7Cayn » 2010-02-08T07:01:28-07:00

I used the aptitude packet manager to install it. I doubt it was the wrong version though.

What i did now is downloading the source from zlib and compiled it into local environment.
/usr/local/includes and such.
recompiled all plugins
and compiled ImageMagick again.

Now it works. Many thanks :D


Return to “Users”

Who is online

Users browsing this forum: Bing [Bot] and 3 guests