Page 1 of 1

error using convert, "missing an image filename"

Posted: 2011-02-09T10:33:33-07:00
by danpaluska

Code: Select all

timelapseguest@timelapse:~$ convert /scratch/tmp*.jpg -average foo.png
convert: missing an image filename `foo.png'.
i've used this line on other machines and not gotten an error.
this is really confusing me...
tried it with a bunch of different convert stuff and always getting this same error where is says the outputfilename is missing...
i've checked permissions and other stuff but still coming up blank. any thoughts?

Re: error using convert, "missing an image filename"

Posted: 2011-02-09T10:41:45-07:00
by fmw42
convert /scratch/tmp*.jpg -average foo.png

convert /scratch/tmp*.jpg -evaluate-sequence mean foo.png

-average was deprecated (though I thought it still worked) in favor of -evaluate-sequence, which allows min, max, mean as options

On my IM Q16 Mac OSX Tiger, the following still works:

convert lena2.jpg zelda3.jpg -average tmp.png

try specifying two or three images explicitly as a test rather than the wild card and see if even that works.

This seems to work fine for me with 5 images:

convert /Users/fred/zelda/zelda* -average tmp2.png

Is your system installed with the png delegate?

Perhaps quotes might help

convert "/Users/fred/zelda/zelda*" -average tmp2.png

Does your directory for creating foo.png have write permissions?

Re: error using convert, "missing an image filename"

Posted: 2011-02-10T12:34:16-07:00
by danpaluska
i have imagemagick 6.3.7 installed on a debian distro.
timelapseguest@timelapse:~$ convert /scratch/tmp*.jpg -evaluate-sequence mean foo.jpg
convert: unrecognized option `-evaluate-sequence'.
and now i just discovered that all the tmp*.jpg files i was trying to average were bogus files and i feel embarrased. average now works...
Thanks and hope i did not waste anyones time. glad to know -evaluate-sequence exists and i am assuming a later version will make that work for me.


Re: error using convert, "missing an image filename"

Posted: 2011-07-09T05:05:04-07:00
by kbirecki
In case anyone runs into this thread that is looking for a resolution to the ImageMagick problem stating "missing an image filename", I found a method that works and made it my first blog entry: ... image.html