Upgrade Ghostscript from 8.71 to 9.05 - libgs.so issue

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
Catch33
Posts: 1
Joined: 2012-04-26T12:01:08-07:00
Authentication code: 13

Upgrade Ghostscript from 8.71 to 9.05 - libgs.so issue

Post by Catch33 » 2012-04-26T12:58:24-07:00

I have ImageMagick 6.2.8 and Ghostscript 8.7.1 playing together nicely. When I uninstall gs 8.7.1 and install version 9.05, I can no longer run this:
convert eps/GY823W-2.eps x2.gif
convert: unable to load module `/usr/lib/ImageMagick-6.2.8/modules-Q16/coders/ps.la': libgs.so.8: cannot open shared object file: No such file or directory.
Installing gs 9.05 blows away libgs.so.8 and puts in libgs.so.9, causing the above problem - I just can't figure out how to get IM to look for libgs.so.9. I've tried installing one of the newer IM binaries but it still looks for libgs.so.8. I've also tried building from source, thinking that ./configure would pick it up - it seemed to based on the configure output text:
checking for Ghostscript...
checking for Ghostscript version... 9.05
but then I get this:
convert eps/GY823W-2.eps x2.gif
convert: no decode delegate for this image format `eps/GY823W-2.eps' @ error/constitute.c/ReadImage/544.
convert: missing an image filename `x2.gif' @ error/convert.c/ConvertImageCommand/3017.
even though when I do 'convert -list format', EPS shows up in the list, and 'eps<=>ps' shows up with I do convert -list delegates. I'm new to IM/GS, and after a few days of banging me head against this, I'm all out of ideas.

OS - Linux

Post Reply