After Update ....

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
betty1978
Posts: 5
Joined: 2011-11-16T04:43:45-07:00
Authentication code: 8675308

After Update ....

Post by betty1978 » 2012-05-03T11:45:11-07:00

Hi,
I have today updatet my debian server with apt-get update and apt-get upgrade and my old image Version 6.3.7 was updatet to 6.6.0-4. The new version have problems with my php scripts and i installed IM 6.3.7 again.

After the update the convert command works fine, but my PHP script make an error:
apache2: DelegateLibrarySupportNotBuiltIn `/var/www/clients/client0/web2/web/designer/fonts/ttf/serife/DejaVuSerif.ttf' (Freetype) @ warning/annotate.c/RenderFreetype/1604.

convert -list configure
Path: /usr/local/lib/ImageMagick-6.3.7/config/configure.xml

Name Value
-------------------------------------------------------------------------------
CC gcc
CFLAGS -g -O2 -Wall -W -pthread
CONFIGURE ./configure
COPYRIGHT Copyright (C) 1999-2008 ImageMagick Studio LLC
CPPFLAGS -I/usr/local/include
CXX g++
CXXFLAGS -g -O2 -Wall -W -pthread
DEFS -DHAVE_CONFIG_H
DELEGATES bzlib fontconfig freetype gvc jpeg jp2 lcms openexr png rsvg tiff wmf x11 xml zlib
DISTCHECK_CONFIG_FLAGS --disable-deprecate --with-quantum-depth=16 --with-djvu=no --with-fontpath=
EXEC-PREFIX /usr/local
HOST x86_64-unknown-linux-gnu
LDFLAGS -L/usr/local/lib -lfreetype -lz
LIB_VERSION 0x637
LIB_VERSION_NUMBER 6,3,7,10
LIBS -lMagick -llcms -ltiff -lfreetype -ljpeg -lfontconfig -lXext -lSM -lICE -lX11 -lXt -lbz2 -lz -lm -lpthread
NAME ImageMagick
PCFLAGS
PREFIX /usr/local
QuantumDepth 16
RELEASE_DATE 05/03/12
VERSION 6.3.7
WEBSITE http://www.imagemagick.org

I think this script makes this problem:

Code: Select all

function WordLength($string, $font, $pointsize, $maxWidth, $wrap) {
	$image = new imagick();
	$annotate = new imagickdraw();
	$annotate->setfont($font);
	$annotate->setFontSize($pointsize);
		
	if($wrap == "wrap") {
		$words = explode(" ", $string);
		$lines = array();
		$current_line = "";
		foreach($words as $word) {
			if($current_line == "") {
				$t_words = $word;
			} 
			else {
				$t_words = "$current_line $word";
			}
			$metrics = $image->queryFontMetrics($annotate, $t_words);
.... .... ...
Before the update it worked just fine, has anyone an idea what can I do?

Bye
Kai Uwe

Post Reply