jpeg2000 color/tone is off

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
areohbee
Posts: 23
Joined: 2010-09-29T21:05:23-07:00
Authentication code: 8675308

jpeg2000 color/tone is off

Post by areohbee »

I was hoping to support conversion to jp2 via image-magick command-line, however color and tone is off (like how things look when icc-profile is wrong..).

Note: I assessed color/tone by comparing source tiff against jp2 in ACDSee and Photoshop.

Any ideas/clues?...

User avatar
fmw42
Posts: 26269
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: jpeg2000 color/tone is off

Post by fmw42 »

What was your exact IM command and your IM version and platform?

Post your input and output images to some free service such as dropbox.com and put the URLs here, so we can examine and test with them.

Sorry, a question such as yours provides no useful information to help us understand the problem.

areohbee
Posts: 23
Joined: 2010-09-29T21:05:23-07:00
Authentication code: 8675308

Re: jpeg2000 color/tone is off

Post by areohbee »

a question such as yours provides no useful information
Just wanted to offer a heads up that jp2 conversion may have color/tone issues.

If you can't reproduce, but you still want to pursue, I will provide more info than this:

* Platform: Windows 7
* IM version: 6.7.3-Q16
(I am not using the latest because the versions I tried after 6.7.3 had a problem that 6.7.3 doesn't have - the problem was reported, but hadn't been fixed at the time of last retry).
* The problem occurred for all the images I tried (a few different types from different sources), as exported from Lightroom 5.6.
* command: convert -format jp2
(I tried a multitude of parameters to go with that, like -define jp2:rate=..., all did what they were supposed to do, but none had any impact on the problem I'm reporting).

Rob

User avatar
fmw42
Posts: 26269
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: jpeg2000 color/tone is off

Post by fmw42 »

Just wanted to offer a heads up that jp2 conversion may have color/tone issues.
You should upgrade to test this or provide your image so others can test on the current IM version. It is likely fixed if it was a bug. But you still have not provided your exact command for us to see if it has correct syntax and to use it to test along with your image.

That old version of IM requires Jasper delegate library to process JP2 files. The current IM uses OpenJpeg, which is more compatible with newer jp2 formats.

see

http://en.wikipedia.org/wiki/JPEG_2000#Libraries

areohbee
Posts: 23
Joined: 2010-09-29T21:05:23-07:00
Authentication code: 8675308

Re: jpeg2000 color/tone is off

Post by areohbee »

Thank you for the time you've invested so far to answer. Unfortunately, I am too busy to pursue right now.

Whether you (or anybody else) can or can't reproduce using the latest version (or whatever version you have, on your platform, your command, your images..) - that would be good to know.

Exact command example: "C:\Program Files\ImageMagick-6.7.3-Q16\convert.exe" "C:\Users\Rob\AppData\Local\Temp\20110728RC153645NB3709_8-bit_c-6.tif" -format jp2 "C:\Users\Rob\AppData\Local\Temp\20110728RC153645NB3709_8-bit_c-6.jp2"

Sorry, I no longer have the image that went with that command.

Perhaps I will have more time to pursue in the future.

PS - thanks for the info about the library switch (did you say v6.7.3 is using the old libraries?).

Cheers,
Rob
Last edited by areohbee on 2014-09-06T20:23:01-07:00, edited 1 time in total.

User avatar
fmw42
Posts: 26269
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: jpeg2000 color/tone is off

Post by fmw42 »

Do you have any other image that shows the same problem. We need to know if it was sRGB or CMYK and whether there was a profile with the image.

Not sure why you use -format? Did you try

convert image.tiff JP2:output.jp2

Perhaps they do the same thing. But I have never use -format.

areohbee
Posts: 23
Joined: 2010-09-29T21:05:23-07:00
Authentication code: 8675308

Re: jpeg2000 color/tone is off

Post by areohbee »

AdobeRGB, and yes: profile was present.

Bear with me and I'll try latest version, and if still no go provide some more info and sample files.

PS: -format syntax was used to cue Lightroom plugin what the output extension was (uses lua pattern matching).

R

User avatar
fmw42
Posts: 26269
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: jpeg2000 color/tone is off

Post by fmw42 »

Do you know that the problem is not with Lightroom?

Sorry, I do not know what "lua pattern matching" is or if that is relevant to JP2 format?

Was your tiff file compressed and if so what kind? That may be a compatibility issue when converting to JP2 (just a thought)?

User avatar
fmw42
Posts: 26269
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: jpeg2000 color/tone is off

Post by fmw42 »

I am getting a color differences. I took one of the Kodak Images with the parrots and opened in my old PS CS and assigned an AdobeRGB profile and saved with no compression as TIF. Then I converted to JP2:

Code: Select all

convert kodim23.tif JP2:kodim23.jp2
The result has different colors. But the Adobe profile did not follow to the output image. So I tried to assign it explicitly as

Code: Select all

convert kodim23.tif -profile /Users/fred/images/profiles/AdobeRGB1998.icc JP2:kodim23b.jp2
but the profile was not in the output image.

This may be the issue. I do not know if JP2 format allows profiles. I am not sure why it would not. But I am not an expert.

But the stripping of profiles could be a bug and causing your issue.

I will report this on the bugs forum.

areohbee
Posts: 23
Joined: 2010-09-29T21:05:23-07:00
Authentication code: 8675308

Re: jpeg2000 color/tone is off

Post by areohbee »

Thanks. jpeg2000 does need icc-profile for proper color/tone - I think you nailed it..

Post Reply