Missing dependencies during ImageMagick installation

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
dokaspar
Posts: 1
Joined: 2015-11-12T06:40:01-07:00
Authentication code: 1151

Missing dependencies during ImageMagick installation

Post by dokaspar » 2015-11-12T07:42:47-07:00

Hi,

I'm trying to build and install ImageMagick from source:
1. I downloaded the RPM here ftp://ftp.imagemagick.org/pub/ImageMagi ... -5.src.rpm
2. I executed the command "rpmbuild --rebuild ImageMagick.src.rpm", that I found in the section "Linux-specific Build instructions" in the Install-unix.txt file (which is part of the src.rpm). This command failed with a list of missing dependencies [1]
3. I could solve this problem by installing all missing dependencies with "yum install ..."
4. In a second step, the RPM should be installed, but this command fails again with missing dependencies:

sudo rpm -ivh /root/rpmbuild/RPMS/x86_64/ImageMagick-6.9.2-5.x86_64.rpm
error: Failed dependencies:
ImageMagick-libs = 6.9.2-5 is needed by ImageMagick-6.9.2-5.x86_64
libMagickCore-6.Q16.so.2()(64bit) is needed by ImageMagick-6.9.2-5.x86_64
libMagickWand-6.Q16.so.2()(64bit) is needed by ImageMagick-6.9.2-5.x86_64

This time, I have no idea where to obtain the missing components...
Yum does not seem to know them and in the Internet I could not find any RPMs that would suit my Redhat Linux:

Linux 2.6.32-573.7.1.el6.x86_64 #1 SMP Thu Sep 10 13:42:16 EDT 2015 x86_64 x86_64 x86_64 GNU/Linux

Any advice would be much appreciated.

Greetings,
Dominik

PS: If I try to install a binary from the official downloads page (e.g., the ImageMagick-6.9.2-5.x86_64.rpm for Redhat / CentOS 7.1 x86_64 RPM), then I get exactly the same error.

-------------------------------------------------------------------------------------------------------
[1] rpmbuild --rebuild ImageMagick-6.9.2-5.src.rpm
-------------------------------------------------------------------------------------------------------
Installing ImageMagick-6.9.2-5.src.rpm
warning: user cristy does not exist - using root
warning: group cristy does not exist - using root
warning: user cristy does not exist - using root
warning: group cristy does not exist - using root
error: Failed build dependencies:
libtiff-devel is needed by ImageMagick-6.9.2-5.x86_64
giflib-devel is needed by ImageMagick-6.9.2-5.x86_64
ghostscript-devel is needed by ImageMagick-6.9.2-5.x86_64
djvulibre-devel is needed by ImageMagick-6.9.2-5.x86_64
libwmf-devel is needed by ImageMagick-6.9.2-5.x86_64
jasper-devel is needed by ImageMagick-6.9.2-5.x86_64
libtool-ltdl-devel is needed by ImageMagick-6.9.2-5.x86_64
lcms2-devel is needed by ImageMagick-6.9.2-5.x86_64
OpenEXR-devel is needed by ImageMagick-6.9.2-5.x86_64
fftw-devel is needed by ImageMagick-6.9.2-5.x86_64
libwebp-devel is needed by ImageMagick-6.9.2-5.x86_64
-------------------------------------------------------------------------------------------------------

Post Reply