Recursive Dependency of ImageMagick libraries while installation.

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
ashishc
Posts: 8
Joined: 2015-12-02T20:10:57-07:00
Authentication code: 1151

Recursive Dependency of ImageMagick libraries while installation.

Post by ashishc » 2015-12-02T20:26:34-07:00

Hi All,

I have downloaded ImageMagick rpm ImageMagick-libs-6.9.2-7.x86_64.rpm. While installing the same, I am getting recursive dependency error related to ImageMagick libraries. Following is the error I am getting

Code: Select all

[root@linux rpms]# rpm -Uvh ImageMagick-6.9.2-7.x86_64.rpm
error: Failed dependencies:
        ImageMagick-libs = 6.9.2-7 is needed by ImageMagick-6.9.2-7.x86_64
        libMagickCore-6.Q16.so.2()(64bit) is needed by ImageMagick-6.9.2-7.x86_64
        libMagickWand-6.Q16.so.2()(64bit) is needed by ImageMagick-6.9.2-7.x86_64
[root@linux rpms]# rpm -Uvh libMagickCore-6_Q16-2-6.9.1.1-246.2.x86_64.rpm
warning: libMagickCore-6_Q16-2-6.9.1.1-246.2.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 4f311b1d: NOKEY
error: Failed dependencies:
        libMagickWand-6.Q16.so.2()(64bit) is needed by libMagickCore-6_Q16-2-6.9.1.1-246.2.x86_64
        libxcb-xlib.so.0()(64bit) is needed by libMagickCore-6_Q16-2-6.9.1.1-246.2.x86_64
[root@linux rpms]# rpm -Uvh libMagickWand-6_Q16-2-6.9.1.1-246.2.x86_64.rpm
warning: libMagickWand-6_Q16-2-6.9.1.1-246.2.x86_64.rpm: Header V3 DSA/SHA1 Signature, key ID 4f311b1d: NOKEY
error: Failed dependencies:
        libMagickCore-6.Q16.so.2()(64bit) is needed by libMagickWand-6_Q16-2-6.9.1.1-246.2.x86_64
[root@linux rpms]#
While trying to install libMagickCore-6_Q16-2-6.9.1.1-246.2.x86_64.rpm, it is showing dependency for libMagickWand-6.Q16.so.2()(64bit) and while trying to install libMagickWand-6_Q16-2-6.9.1.1-246.2.x86_64.rpm, getting libMagickCore-6.Q16.so.2()(64bit) as dependency.

Can anyone help me out in resolving this dependency issue?

Post Reply