IM errors with MediaWiki Install on Server 2008

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
seandotson
Posts: 1
Joined: 2015-12-07T06:35:43-07:00
Authentication code: 1151

IM errors with MediaWiki Install on Server 2008

Post by seandotson » 2015-12-07T06:40:51-07:00

Installed MediaWiki from https://bitnami.com/ on a Windows 7 machine. Worked great.

Then went to install it on our Windows 2008 Server. When I try to upload a JPG I get the following error.

Code: Select all

Error creating thumbnail: convert.exe: RegistryKeyLookupFailed `CoderModulesPath' @ error/module.c/GetMagickModulePath/662.
convert.exe: no decode delegate for this image format `JPEG' @ error/constitute.c/ReadImage/501.
convert.exe: no images defined `C:\Windows\TEMP/transform_4446ada8c241-1.jpg' @ error/convert.c/ConvertImageCommand/3230.
Uploading a PNG results in:

Code: Select all

Error creating thumbnail: convert.exe: unable to load module `C:\Bitnami\mediawiki-1.26.0-0\imagemagick\modules\coders\IM_MOD_RL_PNG_.dll': The specified module could not be found.

@ error/module.c/OpenModule/1282.
convert.exe: no decode delegate for this image format `PNG' @ error/constitute.c/ReadImage/501.
convert.exe: no images defined `C:\Windows\TEMP/transform_3df84dbe286b-1.png' @ error/convert.c/ConvertImageCommand/3230.

Error code: 1
Searching has not gotten me very far. Any suggestions to try?

Post Reply