Building custom location Mac OS X, cannot configure freetype

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
Posts: 1
Joined: 2016-02-17T15:41:22-07:00
Authentication code: 1151

Building custom location Mac OS X, cannot configure freetype

Post by southpaw » 2016-02-17T15:59:05-07:00

I'm trying to build IM to run under Mac OS X El Capitan. My use for the tool is to create images that will subsequently be used for unit testing an xcode project. Because the IM tool will be part of the project structure, and the project has to build both locally on my own system and also on a corporate build server, I cannot use MacPorts, Brew, etc. to install any components, nor do I have root access to the build system. The resulting xcode project and its unit tests must be entirely self-contained within a single directory structure, committed to the git repo, and must not require root access or custom OSX configuration. I can only rely on standard Mac OS X + latest XCode on the build farm.

My desired configuration is to build IM under a "Tools" subdirectory tree in my XCode project, and invoke it from there from a run script phase for a unit test target to create the test images I need in the derived products folder (there will be potentially hundreds or more of these).

I can use a custom --prefix in configure to get IM to build, but it doesn't find the freetype library, that I have also built and installed in the same --prefix area. I've tried adding LDFLAGS with -L and -R, CPPFLAGS with -I, and of course the --prefix as well as --with-freetype=yes and I still get 'no' in the dependencies. The freetype libraries and headers are are correctly located at the paths I'm using.

./configure --prefix='/Users/southpaw/Development/xcodeproject/Tools' --disable-dependency-tracking CPPFLAGS='-I/Users/southpaw/Development/xcodeproject/Tools/include' LDFLAGS='-L/Users/southpaw/Development/xcodeproject/Tools/lib -R/Users/southpaw/Development/xcodeproject/Tools/lib' --with-freetype=yes

I've also tried with just the prefix argument, and using CFLAGS instead of CPPFLAGS.

I still see this in the configure output:

FreeType --with-freetype=yes no

IM is otherwise buildable and functional, but of course using any text commands fails with the missing delegate error.


Post Reply