Installed the last version but old one still comes up.

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
Jean-Pierre Coulon
Posts: 22
Joined: 2016-10-04T02:08:22-07:00
Authentication code: 1151
Location: Nice, France

Installed the last version but old one still comes up.

Post by Jean-Pierre Coulon » 2017-02-26T23:57:28-07:00

I just installed ImageMagick-7.0.5-0-Q8-x64-dll.exe but when I say convert -version I still obtain ImageMagick 6.8.9-4 Q8 x64 2014-06-22. How can I cause "convert" to fetch the last version?

User avatar
fmw42
Posts: 21832
Joined: 2007-07-02T17:14:51-07:00
Location: Sunnyvale, California, USA

Re: Installed the last version but old one still comes up.

Post by fmw42 » 2017-02-27T01:19:20-07:00

In Windows, you must install the legacy components to run convert in IM 7. Alternately, just replace convert with magick and IM 7 should run fine.

Jean-Pierre Coulon
Posts: 22
Joined: 2016-10-04T02:08:22-07:00
Authentication code: 1151
Location: Nice, France

Re: Installed the last version but old one still comes up.

Post by Jean-Pierre Coulon » 2017-02-27T02:36:01-07:00

fmw42 wrote:
2017-02-27T01:19:20-07:00
In Windows, you must install the legacy components to run convert in IM 7
The download page doesn't contain "legacy". Can you explain?
Alternately, just replace convert with magick and IM 7 should run fine.
Yes, thanks.

Bonzo
Posts: 2833
Joined: 2006-05-20T08:08:19-07:00
Location: Cambridge, England

Re: Installed the last version but old one still comes up.

Post by Bonzo » 2017-02-27T04:16:34-07:00

On Windows the old version probably comes up as it is in the environmental path.

When you install version 7 it should ask two questions with a tick box beside each. Something like "add Imagemagick to your environmental path" and "Install legacy components". You want to definatly tick the add to environmental path box.

To manually add or remove the program from the environmental path you can either have a go at reinstalling or do a search for "adding programs to the environmental path". It is not complicated and you can remove the old version as well or just uninstall it.

Jean-Pierre Coulon
Posts: 22
Joined: 2016-10-04T02:08:22-07:00
Authentication code: 1151
Location: Nice, France

Re: Installed the last version but old one still comes up.

Post by Jean-Pierre Coulon » 2017-02-27T05:39:02-07:00

Thanks. Now convert -version gives the 2017 version.

Jean-Pierre Coulon
Posts: 22
Joined: 2016-10-04T02:08:22-07:00
Authentication code: 1151
Location: Nice, France

Re: Installed the last version but old one still comes up.

Post by Jean-Pierre Coulon » 2017-02-27T11:21:55-07:00

Note that with Windows XP the old grandmother's recipe is still needed for the changes to be effective, even with the "install legacy" click: restart your computer! :-) e.g. without the restart, "magick" is not recognized.

Post Reply