Page 2 of 2

Re: High Sierra install

Posted: 2017-12-20T22:16:49-07:00
by philysgdy
I have looked over the file in Github and the delegate X11 is there but as an option
depends_on "jpeg" => :recommended
depends_on "libpng" => :recommended
depends_on "libtiff" => :recommended
depends_on "freetype" => :recommended

depends_on :x11 => :optional
depends_on "fontconfig" => :optional
depends_on "little-cms" => :optional
depends_on "little-cms2" => :optional
depends_on "libwmf" => :optional
depends_on "librsvg" => :optional
depends_on "liblqr" => :optional
depends_on "openexr" => :optional
depends_on "ghostscript" => :optional
depends_on "webp" => :optional
depends_on "openjpeg" => :optional
depends_on "fftw" => :optional
depends_on "pango" => :optional
depends_on :perl => ["5.5", :optional]
now if I knew a little more about code I could unravel it, but alas I don't have experience in this, but because it is optional Brew doesn't install it probably because it doesn't see the flags from XQuartz
any advice would be much appreciated, thanks in advance

Re: High Sierra install

Posted: 2017-12-20T22:47:27-07:00
by fmw42
Sorry, I cannot help as I have no experience with Homebrew. I am surprised since no one else has reported this problem. The only options are to install IM 6 from MacPorts or install the ImageMagick 7 binary. The latter would be easier.

Perhaps one of the other Mac users can provide more information about installing from Homebrew.

Re: High Sierra install

Posted: 2017-12-20T23:36:00-07:00
by philysgdy
Thanks for your efforts on this I will try a binary dump

Re: High Sierra install

Posted: 2017-12-23T06:06:33-07:00
by philysgdy
I got a result from https://stackoverflow.com/questions/446 ... th-xquartz
for all those who venture down this path and get stuck

Re: High Sierra install

Posted: 2017-12-23T10:36:08-07:00
by fmw42
philysgdy wrote:
2017-12-23T06:06:33-07:00
I got a result from https://stackoverflow.com/questions/446 ... th-xquartz
for all those who venture down this path and get stuck
So what was the solution to your issue? What step did you miss?