Tif to PDF conversion error

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
Posts: 1
Joined: 2018-02-01T15:47:03-07:00
Authentication code: 1152

Tif to PDF conversion error

Post by stirfrey » 2018-02-01T16:18:57-07:00

I have a large number of tif's that I'm trying to convert to PDF using a simple command
"convert file.tif file.pdf"
I'm doing this on an Ubuntu Linux system. After a period of time the command errors with the message below.

Bad value 0 for "RowsPerStrip" tag. `_TIFFVSetField' @ error/tiff.c/TIFFErrors/568.

Most of the pages are converted, but in the resulting PDF there are some pages missing. Most of the files I had to convert worked just fine, but I have about 30 or so that are all giving this same error. I've done some googling and digging in the forum but not been able to find any similar errors. What would cause this and is there a way to fix it?


User avatar
Posts: 24457
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: Tif to PDF conversion error

Post by fmw42 » 2018-02-01T18:06:32-07:00

IM uses libtif to process TIFF files. I suppose your tiff files do not conform to proper structure. You could try to edit them with EXIFTOOL. Tiff files should not have a 0 value for RowsPerStrip.

Post Reply