Imagemagick Permission issue on windows server

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
utbl
Posts: 18
Joined: 2016-09-22T01:53:33-07:00
Authentication code: 1151

Imagemagick Permission issue on windows server

Post by utbl » 2018-02-28T01:51:40-07:00

Hi,

so we have a Microsoft Windows Server 2012 R2 Standard running. The server is used for a webapplication which uses imagemagick ffmpeg and another windows tool. The server / webapplication does not work all the time.
First I gave the imagemagick executables 777 permission, if the executables have 77 permission the webapplication works, but after a while the permission for those executables seems to change after if that happens the webapplication does not work anymore.

I already created a thread in the microsoft forum and one told me that I should also ask in the imagemagick forum.

Any idea what could case this and how to fix it, currently I always needs to change the permission on the server to 777 if I see that the webapplication does not work anymore.

Best regards

snibgo
Posts: 10273
Joined: 2010-01-23T23:01:33-07:00
Authentication code: 1151
Location: England, UK

Re: Imagemagick Permission issue on windows server

Post by snibgo » 2018-02-28T04:27:49-07:00

utbl wrote:... after a while the permission for those executables seems to change ...
Well, that's a bug somewhere. IM doesn't change its own permissions. I suggest you track down what is changing those permissions.
snibgo's IM pages: im.snibgo.com

Post Reply