Install IM-6.9.9-40.x86_64.rpm on Centos 6.9

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
ocaballero
Posts: 1
Joined: 2018-04-25T12:37:29-07:00
Authentication code: 1152

Install IM-6.9.9-40.x86_64.rpm on Centos 6.9

Post by ocaballero » 2018-04-25T13:00:56-07:00

Hello, I've inherited an implementation to recreate our Production environment that was assembled by a consulting company into a Staging server. On our production we're currently running RHEL 6.9, IM 6.9.9-40x86_64. On Staging we have CentOS 6.9. I've downloaded the 2 rpm files: ImageMagick-6.9.9-40.x86_64.rpm and ImageMagick-libs-6.9.9-40.x86_64.rpm and tried to install on the CentOS 6.9 server. Regardless of the order I try to install these rpms I receive dependencies notifications. How do I get the required dependencies for these? Below is output:
# rpm -Uvh ImageMagick-6.9.9-40.x86_64.rpm error: Failed dependencies:
ImageMagick-libs(x86-64) = 6.9.9-40 is needed by ImageMagick-6.9.9-40.x86_64
libMagickCore-6.Q16.so.5()(64bit) is needed by ImageMagick-6.9.9-40.x86_64
libMagickWand-6.Q16.so.5()(64bit) is needed by ImageMagick-6.9.9-40.x86_64
libfftw3.so.3()(64bit) is needed by ImageMagick-6.9.9-40.x86_64
liblcms2.so.2()(64bit) is needed by ImageMagick-6.9.9-40.x86_64
liblzma.so.5()(64bit) is needed by ImageMagick-6.9.9-40.x86_64
libMagickCore.so.5()(64bit) is needed by (installed) ImageMagick-c++-6.7.2.7-6.el6.x86_64
libMagickCore.so.5()(64bit) is needed by (installed) inkscape-0.47-10.el6.x86_64
libMagickWand.so.5()(64bit) is needed by (installed) ImageMagick-c++-6.7.2.7-6.el6.x86_64
ImageMagick = 6.7.2.7-6.el6 is needed by (installed) ImageMagick-c++-6.7.2.7-6.el6.x86_64

Thanks in advanced.

Post Reply