exist any way of prevent or remove this error when I use connected components appears a little blob around image?

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
diegomage
Posts: 205
Joined: 2017-03-08T10:12:28-07:00
Authentication code: 1151

exist any way of prevent or remove this error when I use connected components appears a little blob around image?

Post by diegomage »

when i use connected component appears a rare blobs in the image


Image


this is my code

Code: Select all

convert       image.png -define connected-components:area-threshold=60 -define connected-components:mean-color=true -connected-components 4 image2.jpg
Image

in simple view dont see the blob but when I look more i see a blobs

Image


please help me

User avatar
fmw42
Posts: 25932
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: exist any way of prevent or remove this error when I use connected components appears a little blob around image?

Post by fmw42 »

I do not understand your question. What blob? Do not save to JPG. It will change colors due to compressions artifacts. With only 16 colors, you should save to GIF.

Try

Code: Select all

convert image.png -define connected-components:area-threshold=60 -define connected-components:mean-color=true -connected-components 4 image2.gif

diegomage
Posts: 205
Joined: 2017-03-08T10:12:28-07:00
Authentication code: 1151

Re: exist any way of prevent or remove this error when I use connected components appears a little blob around image?

Post by diegomage »

yes very thankyou I will not do this error

Post Reply