Make failure

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
bob.parker
Posts: 2
Joined: 2018-10-15T07:12:19-07:00
Authentication code: 1152

Make failure

Post by bob.parker » 2018-10-15T07:49:01-07:00

I am attempting to build from source on Xubuntu 16.04 because ImageMagick from the repositories is useless.
I have downloaded ImageMagick-7.0.8-12 and it successfully built but make check failed with 2 errors.
As it happened, I did not have the delegates for png and jpg installed so I downloaded, built and installed
libxml2-2.9.6
libpng-1.6.31
lcms2-2.8
jpeg-9b
ghostscript-9.22
freetype-2.8.1
Having done that, make now fails with this message:
CXXLD Magick++/lib/libMagick++-7.Q16HDRI.la
ar: `u' modifier ignored since `D' is the default (see `U')
CC utilities/magick.o
CCLD utilities/magick
MagickCore/.libs/libMagickCore-7.Q16HDRI.so: undefined reference to `GOMP_parallel'
collect2: error: ld returned 1 exit status
Makefile:7043: recipe for target 'utilities/magick' failed
make[1]: *** [utilities/magick] Error 1
make[1]: Leaving directory '/home/bob/Documents/Source/ImageMagick-7.0.8-12'
Makefile:5179: recipe for target 'all' failed
make: *** [all] Error 2
What should I try next?

bob.parker
Posts: 2
Joined: 2018-10-15T07:12:19-07:00
Authentication code: 1152

Re: Make failure

Post by bob.parker » 2018-10-19T08:59:36-07:00

Solved it.
The first thing I tried was cloning the latest ImageMagick from Github and had the same result.
The delegates I installed were named at https://www.imagemagick.org/download/delegates/
The item causing the problem was https://www.imagemagick.org/download/de ... 2.8.tar.gz
I replaced it with https://sourceforge.net/projects/lcms/f ... z/download

The program then built successfully and passed make check also. 8)

Post Reply