Linking to the libraries of a newer version

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
jonotrain
Posts: 12
Joined: 2015-06-07T21:20:12-07:00
Authentication code: 6789

Linking to the libraries of a newer version

Post by jonotrain » 2019-03-19T13:40:02-07:00

I have executables that were written to work with version 6.5 of ImageMagick. I tried installing the older version but unfortunately I get errors whenever I try to make or make install any of the 6.5 packages. So, I installed 6.9 using MacPorts and tried using install_name_tool to just change the libraries in my existing executables to match the names of the new libraries for Image (So I changed libMagick++-6.Q16.5.dylib to libMagick++-6.Q16.8.dylib, etc.) but they are still not working. Is there any way to get these old executables running?

edit: I should add that I get the same error dyld: Library not loaded: @/opt/local/lib/libMagick++-6.Q16.8.dylib, although that is the correct path for that library

Post Reply