Inherited a codebase, there is a bug with the images that are supposed to be rendered

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
cmellor
Posts: 1
Joined: 2020-01-25T20:38:41-07:00
Authentication code: 1152

Inherited a codebase, there is a bug with the images that are supposed to be rendered

Post by cmellor »

I don't know much about ImageMagick at all. I've got a custom developed WordPress plugin that allows you to pass params into a shortcode that in turn builds an ImageMagick command. Here is one of the commands being generated

Code: Select all

convert -background transparent -fill white -gravity Center -font Arial -pointsize 120 -size 1000  caption:"REGISTER\ EARLY!" /home/customer/www/mysite.com/public_html/wp-content/uploads/.image-label-cache/34d6d3287ce500afa0cf800c6242daca.png
and here's the result


Image



Does this result look familiar to anyone here?

User avatar
fmw42
Posts: 26294
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: Inherited a codebase, there is a bug with the images that are supposed to be rendered

Post by fmw42 »

On my Mac OSX ImageMagick 6.9.10.88, it works only, if you escape the !. So it should be \! as follows:

Code: Select all

convert -background transparent -fill white -gravity Center -font Arial -pointsize 120 -size 1000  caption:"REGISTER\ EARLY\!" /home/customer/www/mysite.com/public_html/wp-content/uploads/.image-label-cache/34d6d3287ce500afa0cf800c6242daca.png

Post Reply