Memory allocation failed `Not enough space'

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
User avatar
magick
Site Admin
Posts: 10981
Joined: 2003-05-31T11:32:55-07:00

Post by magick » 2006-05-03T10:42:55-07:00

Two suggestions, if you have the time upgrade to ImageMagick 6.2.7-2, the current release and see if the problem persists otherwise try adding -limit memory 64 -limit map 128 right after 'convert' on the command line. This will force the pixel cache to disk rather than memory. It should work in memory. We tried your command on our 2GB Linux box and it completed without complaint.

User avatar
magick
Site Admin
Posts: 10981
Joined: 2003-05-31T11:32:55-07:00

Post by magick » 2006-05-04T08:25:29-07:00

You could try upgrading to ImageMagick 6.2.7-2, the latest release. You could try setting the memory limit to 1, however, something is not right if your system can't allocate just a few megabytes of memory. Not sure what the problem is. We tried your command under Solaris 10 on a 1GB memory system and it worked without complaint.

User avatar
magick
Site Admin
Posts: 10981
Joined: 2003-05-31T11:32:55-07:00

Post by magick » 2006-05-04T09:18:32-07:00

Your image converts without complaint. We tried ImageMagick 6.2.7 under Linux and 6.2.5 under Solaris 10 and 6.0.8 under Solaris 8.

User avatar
magick
Site Admin
Posts: 10981
Joined: 2003-05-31T11:32:55-07:00

Post by magick » 2006-05-05T09:31:50-07:00

To fix the problem we need to reproduce it. Post a URL to your problem TIFF image so we can download.

User avatar
magick
Site Admin
Posts: 10981
Joined: 2003-05-31T11:32:55-07:00

Post by magick » 2006-05-05T09:45:30-07:00

Ok then, we tried that image and could not reproduce the problem. Since its hanging in the TIFF delegate library, its possible the out of memory condition is coming from TIFF rather than ImageMagick.

Post Reply