png reading problem

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
abhishekv1

png reading problem

Post by abhishekv1 » 2006-06-20T05:40:19-07:00

hi,

I had uninstalled ImageMagick and again installed it of latest version
6.2.7. I also installed the following alongwith it :
jpegsrc.v6b.tar.gz
libpng-1.0.6.tar.gz
libtiff-lzw-compression-kit-1.1.tar.gz
tiff-v3.5.5.tar.gz

After doing the above, I found the latest version of png available which is
libpng-1.2.2.tar.gz, so I installed the same thinking that it would overwrite the previous version. But after installation whenever I process a png file using convert it gives me the following error:
e.g when I tried to process "font_smoking.png" using convert, it gave error -

convert: Application was compiled with png.h from libpng-1.0.6 `font_smoking.png'.
convert: Application is running with png.c from libpng-1.2.2 `font_smoking.png'.
convert: Incompatible libpng version in application and library `font_smoking.png'.

I tried a lot to find a solution to this, but cannot seem to find one. Can
anyone help me on this ?

User avatar
glennrp
Posts: 1147
Joined: 2006-04-01T08:16:32-07:00
Location: Maryland 39.26.30N 76.16.01W

Post by glennrp » 2006-06-21T06:47:09-07:00

After you upgrade libpng to an incompatible version (1.0.x -> 1.2.x) you have to recompile ImageMagick. Incidentally, libpng-1.2.2 is also pretty old. The current version is 1.2.10.

Post Reply