Request: better error logging loading delegates

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
User avatar
magick
Site Admin
Posts: 11063
Joined: 2003-05-31T11:32:55-07:00

Post by magick » 2006-07-26T16:40:27-07:00

Add
  • -debug module
to your command line and see if it provides you with enough information to track the problem. If that fails try
  • -debug all,trace

User avatar
magick
Site Admin
Posts: 11063
Joined: 2003-05-31T11:32:55-07:00

Post by magick » 2006-07-26T20:08:14-07:00

Try building ImageMagick with these configure options under Cygwin:
  • ./configure --disable-installed --enable-delegate-build --enable-shared \
    --disable-static --enable-libtool-verbose --enable-ltdl-convenience \
    --without-gslib --without-gvc --without-wmf \
    --without-jp2

User avatar
magick
Site Admin
Posts: 11063
Joined: 2003-05-31T11:32:55-07:00

Post by magick » 2006-07-27T12:38:46-07:00

We just tried
  • wget ftp://ftp.imagemagick.org/pub/ImageMagi ... -7.tar.bz2
    bunzip2 -c ImageMagick-6.2.8-7.tar.bz2 | tar xvf -
    cd ImageMagick-6.2.8
    touch *
    ./configure --enable-delegate-build --enable-shared --disable-static \
    --with-modules --with-quantum-depth=16 --enable-ltdl-convenience \
    --enable-libtool-verbose
    make
    make install
under the very latest Cygwin release and it compiled, installed, and ran fine.

Post Reply