Page 1 of 1

ImageMagick and DNG files?

Posted: 2007-01-01T13:04:06-07:00
by pbender
HI All,

I'm trying to get ImageMagick to convert DNG files to thumbnails and reduced sized images using scripts I've used for a long time for this purpose.

I can't seem to get ImageMagick to see anything other than embeded the TIFF thumbnail image.

I found some posts in the message archives which leads me to believe this could be an old problem. Has the problem not been fixed yet, or is there some trick I'm missing as to how to get this to work properly?

I'm using version ImageMagick version 6.3.1 which I compiled from source on a Linux system.


Posted: 2007-01-01T13:09:54-07:00
by magick
Post a URL to one of your DNG images so we can download and reproduce the problem.

Posted: 2007-01-01T16:39:38-07:00
by pbender
magick wrote: Post a URL to one of your DNG images so we can download and reproduce the problem.

OK, I've posted one here:
The result of running convert with the option "-geometry 800x600" is here: ... romdng.JPG

For reference, I also posted an in camera created JPEG version of this image here:
I also went ahead and uploaded the results for the same conversion as above on the jpeg ... romjpg.JPG


Posted: 2007-01-01T16:59:59-07:00
by magick
We have a patch in ImageMagick 6.3.1-6 Beta to fix the DNG problem you reported. The update will be available by tommorrow. To ensure the image converts as DNG instead of TIFF, use this command:
  • convert dng:image.dng image.jpg

Posted: 2007-01-03T01:23:41-07:00
by pbender
I've tried ImageMagick 6.3.1-6 Beta now, and I get the same result.

When I convert the image using a command line of the form:

convert dng:image.dng image.jpg

the resulting image.jpg is a 160x120 pixel image, rather than the expected 3872x2592 pixel image I should get from the DNG file. This leads me to believe convert is still finding the embeded TIFF thumbnail instead of the larger RAW image contained in the file.

Any thoughts on where to go from here?


Posted: 2007-01-03T12:28:04-07:00
by magick
6.3.1-6 Beta displays your image properly for us. Make sure you have a modern version of the dcraw program installed.

Posted: 2007-01-04T13:35:44-07:00
by pbender
All is good now :).

Seems there were two problems with what I had tried yesterday.

First, I didn't have dcraw installed on the machine I was working on (I thought I did).

Second, the version of ImageMagick 6.3.1-6 beta I downloaded yesterday wasn't correct for some reason. I checked again today and noticed the file date showed todays date, so I downloaded the file again. With this new 6.3.1-6 beta, the dng files work fine, so long as I prefix them with dng: .

Thanks for your help.