Using Magick++ ... Can't link with VS2005

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Post Reply
Tachoknight
Posts: 8
Joined: 2007-03-03T13:30:14-07:00

Using Magick++ ... Can't link with VS2005

Post by Tachoknight »

Hi all-

I have downloaded and successfully built a single-threaded static config of Magick++ (from the VisualMagic directory) using VS2005sp1. All the projects built successfully: I have a ImageMagick-6.3.2\VisualMagick\lib directory filled with CORE_DB_*.lib and CORE_RL_*.lib files (as well as the X11 stub libs). I wrote a quick test program in VS2005, included Magick++, namespace Magick, etc, etc...it compiles fine, but always fails on linking complaining about the unresolved external Magick:Image::~Image(void), as well as write, magick, and read. Basically, standard "include this lib file and you're set" kind of problem.

Problem is, I have included it in the project...I included all the DB files in the debug config, RL in the release config, and I still get this error. I've tried #pragma comment(lib, "Core_DB_Magick++_.lib"), etc (added all of them) and same result.

Any idea what I'm doing wrong here? I'm now even more without a clue than when I started. :)

Thanks,

Tacho

User avatar
magick
Site Admin
Posts: 11226
Joined: 2003-05-31T11:32:55-07:00

Re: Using Magick++ ... Can't link with VS2005

Post by magick »

ImageMagick includes Magick++ demo projects, generally found in c:\Program Files\ImageMagick-6.3.3\Magick++_demos. Fire up the button project and make sure it compiles and runs properly then use it as a template for your own project.

Post Reply