.fon font files don't seem to work.

Questions and postings pertaining to the usage of ImageMagick regardless of the interface. This includes the command-line utilities, as well as the C and C++ APIs. Usage questions are like "How do I use ImageMagick to create drop shadows?".
Locked
troyd1
Posts: 73
Joined: 2007-07-29T17:13:19-07:00

.fon font files don't seem to work.

Post by troyd1 »

I have been trying to understand the font usage. If th font file is a ttf, it works fine referencing the file, but if the file is a .fon file, it does not work. Should this work? I am on a windows system.

Thanks, Troy

Bonzo
Posts: 2971
Joined: 2006-05-20T08:08:19-07:00
Location: Cambridge, England

Re: .fon font files don't seem to work.

Post by Bonzo »

I do not think .fon are supported; I always use .ttf fonts.
-font name
use this font when annotating the image with text.

Use the -list option with a 'Type' argument for a list of -font that IM knows about by name. Or you can specify a font file for direct use.

You can tag a font to specify whether it is a PostScript, TrueType, or OPTION1 font. For example, Arial.ttf is a TrueType font, ps:helvetica is PostScript, and x:fixed is X11.

User avatar
anthony
Posts: 8884
Joined: 2004-05-31T19:27:03-07:00
Authentication code: 8675308
Location: Brisbane, Australia

Re: .fon font files don't seem to work.

Post by anthony »

There are a lot of fonts that the 'freetype' library is suposed to understand but which IM does not pass to that library correctly.

One such group is the X windows fonts whcih ONLY work if an interactive X server display is running.

I think .fon files may also fall into this catagory.

All you can do is report a bug on the bugs forum.
Anthony Thyssen -- Webmaster for ImageMagick Example Pages
https://imagemagick.org/Usage/

Locked