SVG native blob support on Debian

MagickWand for PHP is an object-oriented PHP interface to ImageMagick. Use this forum to discuss, make suggestions about, or report bugs concerning MagickWand for PHP.
Post Reply
RJT
Posts: 1
Joined: 2012-06-01T08:59:11-07:00
Authentication code: 13

SVG native blob support on Debian

Post by RJT » 2012-06-01T09:19:48-07:00

Hi,

I'm writing a PHP script that needs to save an SVG blob as a PNG. The code to do so looks pretty simple, but I get the error 'no decode delegate for this image format' when I try.

Running 'identify -list format' from the terminal yields this:
<snip>
SVG SVG rw+ Scalable Vector Graphics (RSVG 2.36.0)
SVGZ SVG rw+ Compressed Scalable Vector Graphics (RSVG 2.36.0)
<snip>

So, I have SVG support, but I gather the lack of an asterisk beside the format name indicates that I don't have native blob support for SVG and that's what I need. I tried searching for relevant packages and installing them, but that hasn't helped (see the list below). What package(s) do I need to install get get SVG native blob support? Or do I need to install ImageMagick from source?

Cheers,
R

Code: Select all

dpkg --get-selections | egrep '(magick|svg)'
imagemagick                    install
imagemagick-common             install
libgraphicsmagick3             install
libmagick++3                   install
libmagick++4                   deinstall
libmagick++5:amd64             install
libmagickcore3                 install
libmagickcore3-extra           install
libmagickcore4                 deinstall
libmagickcore5:amd64           install
libmagickcore5-extra:amd64     install
libmagickwand3                 install
libmagickwand4                 deinstall
libmagickwand5:amd64           install
libqt4-svg:amd64               install
librsvg2-2:amd64               install
librsvg2-common:amd64          install
libsmokeqtsvg4-3               deinstall
libsvga1:amd64                 install
perlmagick                     install
php5-imagick                   install


Post Reply