Core dumping on FreeBSD 6.1

MagickWand for PHP is an object-oriented PHP interface to ImageMagick. Use this forum to discuss, make suggestions about, or report bugs concerning MagickWand for PHP.
Post Reply
aego

Core dumping on FreeBSD 6.1

Post by aego » 2006-08-02T15:39:38-07:00

FreeBSD 6.1/i386

php5-5.1.4
php-magickwand-0.1.8_1
ImageMagick-6.2.8.5

(installed from ports)

cat /usr/local/etc/php/extensions.ini:

Code: Select all

extension=exif.so
extension=ftp.so
extension=gd.so
extension=gettext.so
extension=iconv.so
extension=mbstring.so
extension=mcrypt.so
extension=mhash.so
extension=mysql.so
extension=pcre.so
extension=zlib.so
extension=pdo.so
extension=posix.so
extension=session.so
extension=simplexml.so
extension=sockets.so
extension=tokenizer.so
extension=xml.so
extension=dom.so
extension=xmlreader.so
extension=xmlwriter.so
extension=zip.so
extension=magickwand.so

/usr/local/bin/php -v

Code: Select all

PHP 5.1.4 (cli) (built: Aug  3 2006 01:58:42)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
Segmentation fault: 11 (core dumped)
(there are lot of coredumps in /var/log/messages too)

Code: Select all

Aug  1 15:51:43 **** kernel: pid 5100 (httpd), uid 80: exited on signal 11
gdb php php.core

Code: Select all

GNU gdb 6.1.1 [FreeBSD]
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-marcel-freebsd"...(no debugging symbols found)...
Core was generated by `php'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /lib/libcrypt.so.3...(no debugging symbols found)...done.
Loaded symbols for /lib/libcrypt.so.3
Reading symbols from /lib/libm.so.4...(no debugging symbols found)...done.
Loaded symbols for /lib/libm.so.4
Reading symbols from /usr/local/lib/libxml2.so.5...(no debugging symbols found)...done.
Loaded symbols for /usr/local/lib/libxml2.so.5
Reading symbols from /lib/libz.so.3...(no debugging symbols found)...done.
Loaded symbols for /lib/libz.so.3
Reading symbols from /usr/local/lib/libiconv.so.3...(no debugging symbols found)...done.
Loaded symbols for /usr/local/lib/libiconv.so.3
Reading symbols from /lib/libc.so.6...(no debugging symbols found)...done.
Loaded symbols for /lib/libc.so.6
Reading symbols from /libexec/ld-elf.so.1...(no debugging symbols found)...done.
Loaded symbols for /libexec/ld-elf.so.1
#0  0x28d67154 in ?? ()
(gdb) bt

Code: Select all

#0  0x28d67154 in ?? ()
#1  0x284fa7cb in __cxa_finalize () from /lib/libc.so.6
#2  0x284fa406 in exit () from /lib/libc.so.6
#3  0x081ab88d in main ()
disable MagickWand,
cat /usr/local/etc/php/extensions.ini:

Code: Select all

extension=exif.so
extension=ftp.so
extension=gd.so
extension=gettext.so
extension=iconv.so
extension=mbstring.so
extension=mcrypt.so
extension=mhash.so
extension=mysql.so
extension=pcre.so
extension=zlib.so
extension=pdo.so
extension=posix.so
extension=session.so
extension=simplexml.so
extension=sockets.so
extension=tokenizer.so
extension=xml.so
extension=dom.so
extension=xmlreader.so
extension=xmlwriter.so
extension=zip.so
;extension=magickwand.so
php -v

Code: Select all

PHP 5.1.4 (cli) (built: Aug  3 2006 01:58:42)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies
(no core dump)

aego

The problem was in JPEG2000

Post by aego » 2006-08-03T16:49:32-07:00

I think I've found solution:

Code: Select all

cd /usr/ports/graphics/ImageMagick
make deinstall
make -DWITHOUT_IMAGEMAGICK_JPEG2000 \
install clean
Works fine for me, I'm happy 8)

aego

Post by aego » 2006-08-04T17:19:54-07:00

stl wrote: How did you track this down? It's been a minor irritation of mine, but with no useful debugging info it would have been a time consuming matter of disabling one feature at a time.

Accidentally. Built stripped version without many features and noticed that no more faults. Then disabling features one by one. Yes, a lot of compiling...

Next week I'll going to check it on another hardware.

Do you got the same results?

Post Reply