Warning: Version warning: Imagick was compiled against Image Magick version 1681 but version 1682 is loaded.

IMagick is a native PHP extension to create and modify images using the ImageMagick API. ImageMagick Studio LLC did not write nor does it maintain the IMagick extension, however, IMagick users are welcome to discuss the extension here.
Post Reply
le0m
Posts: 2
Joined: 2015-11-24T23:39:34-07:00
Authentication code: 1151

Warning: Version warning: Imagick was compiled against Image Magick version 1681 but version 1682 is loaded.

Post by le0m » 2015-11-24T23:50:16-07:00

I get this error each time I execute a PHP command in my console:
Warning: Version warning: Imagick was compiled against Image Magick version 1681 but version 1682 is loaded. Imagick will run but may behave surprisingly in Unknown on line 0
I have the folowing tools installed on my Windows 7 x64 Machine:

ImageMagick-6.9.2-6-Q16-x86-dll.exe (Windows Installer)
PHP 5.6.12 x86 ts (via XAMPP)
php_imagick-3.3.0rc2-5.6-ts-vc11-x86.zip (PHP Extension .dll)

I also tried these extension dlls:
php_imagick-3.3.0rc1-5.6-ts-vc11-x86.zip
php_imagick-3.1.2-5.6-ts-vc11-x86.zip

None fixed the problem.

Does anyone know why I get this error message and what I can do about it?

Bonzo
Posts: 2850
Joined: 2006-05-20T08:08:19-07:00
Location: Cambridge, England

Re: Warning: Version warning: Imagick was compiled against Image Magick version 1681 but version 1682 is loaded.

Post by Bonzo » 2015-11-25T00:56:55-07:00

If it works I would not worry a lot of people including myself can not get Imagick working localy; not that I really care.

Imagick is compiled in visual basic? against Imagmagick and then you need the correct versions of Imagick, Imagemagick, possibly php and compiled with the correct version of visual basic to get it to work.

For your information Imagick is not written or maintained by the authors of Imagemagick.

le0m
Posts: 2
Joined: 2015-11-24T23:39:34-07:00
Authentication code: 1151

Re: Warning: Version warning: Imagick was compiled against Image Magick version 1681 but version 1682 is loaded.

Post by le0m » 2015-12-03T04:34:00-07:00

>If it works I would not worry a lot of people including myself cannot get Imagick working locally; not that I really care.
The warning appears on every php related command, even if imagick isn't involved. I can't take it anymore :?
>Imagick is compiled in visual basic? against Imagmagick and then you need the correct versions of Imagick, Imagemagick, possibly php and compiled with the correct version of visual basic to get it to work.
Getting ImageMagick run with PHP was always a struggle for me..
>For your information Imagick is not written or maintained by the authors of Imagemagick.
Ah ok, I got that wrong.. sry.

Thanks for your information!

Bonzo
Posts: 2850
Joined: 2006-05-20T08:08:19-07:00
Location: Cambridge, England

Re: Warning: Version warning: Imagick was compiled against Image Magick version 1681 but version 1682 is loaded.

Post by Bonzo » 2015-12-03T04:46:16-07:00

Ah ok, I got that wrong.. sry.
That's OK; it was a statement of fact not a reprimand :)

Like you I have had problems getting it installed as well and gave up with it last time.

I use the Imagemagick command line version instead of Imagick as it has more features and I find easier to understand. I can not get my head around classes which does not help.

musicmaster
Posts: 7
Joined: 2016-02-14T07:50:18-07:00
Authentication code: 1151

Re: Warning: Version warning: Imagick was compiled against Image Magick version 1681 but version 1682 is loaded.

Post by musicmaster » 2016-06-08T04:23:21-07:00

Bonzo wrote:If it works I would not worry a lot of people including myself can not get Imagick working localy; not that I really care.
I didn't care about this warning either - until I tried to install Composer. Composer simply refuses to be installed because of this warning. And it doesn't matter that I want to use it for something unrelated.

I hope that someday someone will take responsibility to provide a package of fitting Imagick and Image Magick for WIndows. This is installation hell.

expandbadelynge424
Posts: 1
Joined: 2016-10-06T01:11:42-07:00
Authentication code: 1151

Re: Warning: Version warning: Imagick was compiled against Image Magick version 1681 but version 1682 is loaded.

Post by expandbadelynge424 » 2016-10-08T02:58:53-07:00

I did the following:

Code: Select all

brew rm php70-imagick
brew install --build-from-source php70-imagick
And now the warning is gone!

Post Reply