PHP 7.1 cannot use current version of Imagick

IMagick is a native PHP extension to create and modify images using the ImageMagick API. ImageMagick Studio LLC did not write nor does it maintain the IMagick extension, however, IMagick users are welcome to discuss the extension here.
Post Reply
TomXampp
Posts: 13
Joined: 2015-12-02T00:21:23-07:00
Authentication code: 1151

PHP 7.1 cannot use current version of Imagick

Post by TomXampp » 2016-12-02T09:49:57-07:00

I used the most recent version of Imagick (php_imagick-3.4.3rc1-7.0-ts-vc14-x86.zip) successfully with XAMPP/PHP 7.0.13. localhost on Windows. Today, PHP 7.1 has been released. Upon installation, it fails to load Imagick, reporting this error:
[02-Dec-2016 16:46:32 UTC] PHP Warning: PHP Startup: imagick: Unable to initialize module Module compiled with module API=20151012
PHP compiled with module API=20160303 These options need to match in Unknown on line 0
Is there an Imagick DLL for PHP 7.1 that will be released soon? Or is there a solution with the current Imagick?

User avatar
fmw42
Posts: 22105
Joined: 2007-07-02T17:14:51-07:00
Location: Sunnyvale, California, USA

Re: PHP 7.1 cannot use current version of Imagick

Post by fmw42 » 2016-12-02T10:00:30-07:00

The Imagemagick developers do not maintain Imagick. That is up to the person who developed it. Hopefully he will respond.

Post Reply