Error with ImageMagick version

IMagick is a native PHP extension to create and modify images using the ImageMagick API. ImageMagick Studio LLC did not write nor does it maintain the IMagick extension, however, IMagick users are welcome to discuss the extension here.
Post Reply
igue
Posts: 1
Joined: 2017-04-04T00:50:52-07:00
Authentication code: 1151

Error with ImageMagick version

Post by igue » 2017-04-04T02:43:52-07:00

Hi,
I have to install Image Magick on Windows 7 Professional.
Surfing the internet I found out that the version I need is
ImageMagick 6.8.9-1 Q16 x86 2014-05-08

I did not found the version I need, so I have downloaded and installed the version 7; When I look into the module details in the phpinfo, I see
ImageMagick number of supported formats: 0
and
ImageMagick supported formats: no value
When I try to use it with PHP, I get
Fatal error: Uncaught exception 'ImagickException' with message 'unable to open module file `C:\Windows\system32\config\systemprofile\.magick\IM_MOD_RL_png_.dll': No such file or directory @ warning/module.c/GetMagickModulePath/812'

I found out that I do not have the directory.
Reading on forums (such as StackOverflow and simlars) I discovered that the version of ImageMagick that I have is too recent for the IMagick extension.
Note that I can't install a newer version of IMagick because it can't work with the actual server configuration.
So I suppose that I have to install an older version of ImageMagick (the one I have mentioned before); the problem is that it can not be found on internet.
Does anyone know how can I resolve this problem?

snibgo
Posts: 9391
Joined: 2010-01-23T23:01:33-07:00
Authentication code: 1151
Location: England, UK

Re: Error with ImageMagick version

Post by snibgo » 2017-04-04T03:53:30-07:00

Perhaps the latest v6 version, v6.9.8-3 will do. See http://legacy.imagemagick.org/script/bi ... hp#windows
snibgo's IM pages: im.snibgo.com

Post Reply