Imagick not working any more after a reboot of Windows 10

IMagick is a native PHP extension to create and modify images using the ImageMagick API. ImageMagick Studio LLC did not write nor does it maintain the IMagick extension, however, IMagick users are welcome to discuss the extension here.
Post Reply
Defacta
Posts: 9
Joined: 2017-04-19T03:48:21-07:00
Authentication code: 1151

Imagick not working any more after a reboot of Windows 10

Post by Defacta » 2017-04-26T09:41:26-07:00

Hello,

Pretty strange, everything was working fine for my installation of Imagick and after a reboot of my computer I now have the error when I start Apache from xampp:
the procedure entry point PixelGetFuzz could not be located in the dynamic link library c:\xampp\php\ext\php_imagick.dll

I don't know what I did and I don't know what to check. Imagemagick is intalled on c:\imagemagick.
Version:

Code: Select all

convert --version
    Version: ImageMagick 6.9.3-10 Q16 x86 2016-05-04 http://www.imagemagick.org
    Copyright: Copyright (C) 1999-2015 ImageMagick Studio LLC
    License: http://www.imagemagick.org/script/license.php
    Visual C++: 180040629
    Features: Cipher DPC Modules OpenMP
    Delegates (built-in): bzlib cairo flif freetype jng jp2 jpeg lcms lqr openexr pangocairo png ps rsvg tiff webp xml zlib
Xampp Control Panel version: 3.2.2
php version: 5.6.23

What can I do or check ?

Thanks,
Vincent.

User avatar
fmw42
Posts: 22102
Joined: 2007-07-02T17:14:51-07:00
Location: Sunnyvale, California, USA

Re: Imagick not working any more after a reboot of Windows 10

Post by fmw42 » 2017-04-26T09:44:35-07:00

Is it Imagick that is not working or ImageMagick?

Try running ImageMagick in the command line and see if it is from ImageMagick. If that works, then it is Imagick that my be the problem.

Defacta
Posts: 9
Joined: 2017-04-19T03:48:21-07:00
Authentication code: 1151

Re: Imagick not working any more after a reboot of Windows 10

Post by Defacta » 2017-04-26T10:03:38-07:00

Yes, Imagemagick is working fine, this convert command worked:

Code: Select all

convert canvas1.png -resize 1000x1000 here.png
I tried to download another php_imagick.dll which is in the folder C:\xampp\php\ext and now I have another error message:

the procedure entry point PixelGetAlphaQuantum could not be located in the dynamic link library c:\xampp\php\ext\php_imagick.dll

It's like I don't have the right php dll for my installation of imagemagick. Where to find the good one?

snibgo
Posts: 9403
Joined: 2010-01-23T23:01:33-07:00
Authentication code: 1151
Location: England, UK

Re: Imagick not working any more after a reboot of Windows 10

Post by snibgo » 2017-04-26T10:07:43-07:00

If it worked before the reboot but not after, then the reboot caused the problem. A reboot doesn't normally change files, but does system variables etc that have been only temporarily set.

I don't use IMagick or PHP, and wouldn't know where to look.
snibgo's IM pages: im.snibgo.com

Defacta
Posts: 9
Joined: 2017-04-19T03:48:21-07:00
Authentication code: 1151

Re: Imagick not working any more after a reboot of Windows 10

Post by Defacta » 2017-04-26T10:38:22-07:00

Ok, found and well stay close on your seat! :shock:

It was because of GraphicsMagick http://www.graphicsmagick.org/ which I installed last week after php Imagick, I didn't restarted Apache from this GraphicsMagick installation.
So what I did is : I uninstalled GraphicsMagick, Imagemagick and I reinstalled Imagemagick, reput the file php_imagick.dll I was using.

And now, everything is working like a charm.

It was because of GraphicsMagick, how is it possible?

Thanks you all for your time and your help.

snibgo
Posts: 9403
Joined: 2010-01-23T23:01:33-07:00
Authentication code: 1151
Location: England, UK

Re: Imagick not working any more after a reboot of Windows 10

Post by snibgo » 2017-04-26T11:13:01-07:00

Glad you've solved it. I suppose when Apache or something started it checked for software. After the reboot, it found GraphicsMagick but you needed it to find ImageMagick.
snibgo's IM pages: im.snibgo.com

Post Reply