Install fonts on shared host (Hostgator)

IMagick is a native PHP extension to create and modify images using the ImageMagick API. ImageMagick Studio LLC did not write nor does it maintain the IMagick extension, however, IMagick users are welcome to discuss the extension here.
Post Reply
harshad_gole
Posts: 1
Joined: 2017-10-18T01:51:04-07:00
Authentication code: 1151

Install fonts on shared host (Hostgator)

Post by harshad_gole » 2017-10-18T01:57:31-07:00

I have Developed online PDF to JPG portal for my website. I am having the problem with some PDF cuz of a font.

I get this Error while converting them into JPG

Code: Select all

Error: /invalidaccess in --run-- Operand stack: --dict:7/16(L)-- F3 44 --dict:5/5(L)-- --dict:5/5(L)-- SansSerif --dict:11/12(ro)(G)-- --nostringval-- CIDFontObject --dict:6/6(L)-- --dict:6/6(L)-- 8344 --dict:6/6(L)-- --nostringval-- PDFCIDFontName SansSerif Execution stack: %interp_exit .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval-- --nostringval-- --nostringval-- false 1 %stopped_push 1862 1 3 %oparray_pop 1861 1 3 %oparray_pop 1845 1 3 %oparray_pop --nostringval-- --nostringval-- 2 1 1 --nostringval-- %for_pos_int_continue --nostringval-- --nostringval-- --nostringval-- --nostringval-- %array_continue --nostringval-- false 1 %stopped_push --nostringval-- %loop_continue --nostringval-- --nostringval-- --nostringval-- --nostringval-- --nostringval-- --nostringval-- %array_continue --nostringval-- --nostringval-- --nostringval-- --nostringval-- --nostringval-- Dictionary stack: --dict:1154/1684(ro)(G)-- --dict:1/20(G)-- --dict:75/200(L)-- --dict:75/200(L)-- --dict:106/127(ro)(G)-- --dict:286/300(ro)(G)-- --dict:22/25(L)-- --dict:4/6(L)-- --dict:21/40(L)-- --dict:1/1(ro)(G)-- Current allocation mode is local

Not for only this font. there are several fonts like Verdana, Robota Etc.

snibgo
Posts: 9404
Joined: 2010-01-23T23:01:33-07:00
Authentication code: 1151
Location: England, UK

Re: Install fonts on shared host (Hostgator)

Post by snibgo » 2017-10-18T03:09:58-07:00

What version of IM? What version of Ghostscript?

The error is coming from GS, so if that is old, I suggest you upgrade it.

If it fails with current versions of IM and GS, I suggest you provide a link to the PDF.
snibgo's IM pages: im.snibgo.com

Post Reply