Installation problems - SOLVED

Questions and postings pertaining to the development of ImageMagick, feature enhancements, and ImageMagick internals. ImageMagick source code and algorithms are discussed here. Usage questions which are too arcane for the normal user list should also be posted here.
Post Reply
boognish

Installation problems - SOLVED

Post by boognish » 2007-12-19T11:56:56-07:00

Hello all,

I am having problems installing the most current version of ImageMagick. Any help is greatly appreciated.

==========
Environment
CENTOS Enterprise 4.5 x86_64
Apache/1.3.39
PHP Version: 5.2.4
==========

Attempting to install via yum or up2date installs fine, but retrieves an old version which is incompatible with Imagick-2.0.1, so I am attempting to install the rpm/binary release (ImageMagick-6.3.7-6.x86_64.rpm) downloaded from the ImageMagick website. When I do so, I get the following list of missing dependencies:

libHalf.so.6()(64bit) is needed by ImageMagick-6.3.7-6.x86_64
libIex.so.6()(64bit) is needed by ImageMagick-6.3.7-6.x86_64
libIlmImf.so.6()(64bit) is needed by ImageMagick-6.3.7-6.x86_64
libIlmThread.so.6()(64bit) is needed by ImageMagick-6.3.7-6.x86_64
libImath.so.6()(64bit) is needed by ImageMagick-6.3.7-6.x86_64
libgs.so.8()(64bit) is needed by ImageMagick-6.3.7-6.x86_64
libgvc.so.4()(64bit) is needed by ImageMagick-6.3.7-6.x86_64
libjasper.so.1()(64bit) is needed by ImageMagick-6.3.7-6.x86_64
liblcms.so.1()(64bit) is needed by ImageMagick-6.3.7-6.x86_64
libpng12.so.0(PNG12_0)(64bit) is needed by ImageMagick-6.3.7-6.x86_64
rtld(GNU_HASH) is needed by ImageMagick-6.3.7-6.x86_64

Of these dependencies, I think only libpng12.so.0 actually exists on the server.

I'm fairly familiar with *nix, but not in the installation process, mainly webserver.
I have root access.

My questions are:
1. Is there a way to force yum to grab the current version
2. How do I get these dependencies?

Thanks
Last edited by boognish on 2007-12-20T00:02:42-07:00, edited 1 time in total.

User avatar
magick
Site Admin
Posts: 10788
Joined: 2003-05-31T11:32:55-07:00

Re: Installation problems

Post by magick » 2007-12-19T13:16:11-07:00

Try building from the source RPM (srpm). That will build to your environment.

boognish

Re: Installation problems

Post by boognish » 2007-12-19T14:10:00-07:00

Thanks for the quick response, magick.

I downloaded ImageMagick-6.3.7-6.tar.gz, unzipped and received the following when attempting to configure and make install:

====================
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/libX11.so when searching for -lX11
/usr/bin/ld: skipping incompatible /usr/X11R6/lib/libX11.a when searching for -lX11
/usr/bin/ld: cannot find -lX11
collect2: ld returned 1 exit status
make[1]: *** [magick/libMagick.la] Error 1
make[1]: Leaving directory `/home/temp/ImageMagick-6.3.7'
make: *** [install] Error 2
=====================

/usr/X11R6/lib/libX11.so is a link to libX11.so.6.2

User avatar
magick
Site Admin
Posts: 10788
Joined: 2003-05-31T11:32:55-07:00

Re: Installation problems

Post by magick » 2007-12-19T15:03:22-07:00

Try this:
  • ./configure --without-x
    make

boognish

Re: Installation problems

Post by boognish » 2007-12-20T00:01:12-07:00

That got it. Thanks again for your help magick.

Post Reply