logging to file not working

Questions and postings pertaining to the development of ImageMagick, feature enhancements, and ImageMagick internals. ImageMagick source code and algorithms are discussed here. Usage questions which are too arcane for the normal user list should also be posted here.

logging to file not working

Postby deepakdeore2004 » 2013-08-02T04:34:13+00:00

imagemagick-common version: 8:6.6.9.7-5ubuntu3.2

I have made the below settings in log.xml.

<logmap>
<log events="All"/>
<log output="file"/>
<log filename="/path/to/log/Magick-%g.log"/>
<log generations="3"/>
<log limit="2000"/>
<log format="%t %r %u %v %d %c[%p]: %m/%f/%l/%d\n %e"/>
</logmap>

after making these changes i ran below command but the logs are not generating to a file.

time convert -alpha off -density 300x300 -adaptive-resize 1000 -depth 8 test.pdf test.png

If "-debug all" is added into command then logs are coming to stdout but i want the logs in a file which is not working.
deepakdeore2004
 
Posts: 2
Joined: 2013-08-02T04:26:26+00:00

Re: logging to file not working

Postby magick » 2013-08-02T04:54:15+00:00

We can reproduce the problem you posted and have a patch in ImageMagick 6.8.6-8 Beta available by sometime tomorrow. Thanks.
User avatar
magick
Site Admin
 
Posts: 9704
Joined: 2003-05-31T11:32:55+00:00

Re: logging to file not working

Postby deepakdeore2004 » 2013-08-05T01:36:49+00:00

Is the patch available ?
Also could you please inform how to patch on Ubuntu 12.04 ?
deepakdeore2004
 
Posts: 2
Joined: 2013-08-02T04:26:26+00:00


Return to Developers

Who is online

Users browsing this forum: No registered users and 2 guests