Problem building from source using VS2015

Questions and postings pertaining to the development of ImageMagick, feature enhancements, and ImageMagick internals. ImageMagick source code and algorithms are discussed here. Usage questions which are too arcane for the normal user list should also be posted here.
Post Reply
eldiener
Posts: 10
Joined: 2012-03-29T08:15:10-07:00
Authentication code: 8675308

Problem building from source using VS2015

Post by eldiener » 2016-11-01T07:45:00-07:00

Trying to build IM from source using VS2015 I get this error:

..\..\ImageMagick\MagickCore\accelerate.c(4574): error C2039: 'x': is not a member of 'cl_float2'
C:\Program Files\NVIDIA GPU Computing Toolkit\CUDA\v6.0\include\CL/cl_platform.h(1023): note: see declaration of 'cl_float2'

It looks like IM is picking up something from OpenCl which is not working. Why IM is using OpenCl or why this is not compiling is beyond me.

Anybody have a clue how to fix this ?

User avatar
fmw42
Posts: 25392
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: Problem building from source using VS2015

Post by fmw42 » 2016-11-01T08:25:07-07:00

I am not a Windows user, but see

http://www.imagemagick.org/script/insta ... hp#windows
http://legacy.imagemagick.org/script/in ... hp#windows

Please do not post multiple times about the same issue

eldiener
Posts: 10
Joined: 2012-03-29T08:15:10-07:00
Authentication code: 8675308

Re: Problem building from source using VS2015

Post by eldiener » 2016-11-01T08:27:55-07:00

fmw42 wrote:I am not a Windows user, but see

http://www.imagemagick.org/script/insta ... hp#windows
http://legacy.imagemagick.org/script/in ... hp#windows

Please do not post multiple times about the same issue
I just unchecked OpenCL in the configure program to avoid this error. Thanks !

User avatar
dlemstra
Posts: 1567
Joined: 2013-05-04T15:28:54-07:00
Authentication code: 6789
Contact:

Re: Problem building from source using VS2015

Post by dlemstra » 2016-11-01T12:30:55-07:00

It appears we were using a non portable way to access the x/y values of a cl_float2. This will be resolved in the next version of ImageMagick 7.
.NET + ImageMagick = Magick.NET https://github.com/dlemstra/Magick.NET, @MagickNET, Donate

eldiener
Posts: 10
Joined: 2012-03-29T08:15:10-07:00
Authentication code: 8675308

Re: Problem building from source using VS2015

Post by eldiener » 2016-11-02T07:42:09-07:00

Thanks for the reply about the non portable functionality.

Post Reply