Instructions building from source using Visual Studio are wrong

Questions and postings pertaining to the development of ImageMagick, feature enhancements, and ImageMagick internals. ImageMagick source code and algorithms are discussed here. Usage questions which are too arcane for the normal user list should also be posted here.
Post Reply
eldiener
Posts: 10
Joined: 2012-03-29T08:15:10-07:00
Authentication code: 8675308

Instructions building from source using Visual Studio are wrong

Post by eldiener » 2016-11-01T08:10:02-07:00

The instructions for building IM from source using Visual Studio on Windows has nothing to do with the reality of the latest source distribution. Among the many incorrect items at http://www.imagemagick.org/script/insta ... hp#windows and http://www.imagemagick.org/script/advan ... lation.php are:

1) The configuration tool has nothing in its start screen about VC++6 or VC++7. They are a bit old.
2) The default is Dynamic MT runtimes and not the Static MT runtimes.
3) There is no Static single-threaded runtimes.
4) There is nothing in the configure program about x11 libraries.
5) There's no button for editing "magick_config.h" and in fact there is no "magick_config.h" at all.
6) The generated solution contains no "All" project.
7) There is no checkbox in the configure program or "Generate all utility projects with full paths rather then relative paths."

and on and on...

Would it really be that hard to keep the doc for building from source under Windows using Visual Studio somewhat up-to-date ?

User avatar
dlemstra
Posts: 1557
Joined: 2013-05-04T15:28:54-07:00
Authentication code: 6789
Contact:

Re: Instructions building from source using Visual Studio are wrong

Post by dlemstra » 2016-11-01T12:33:08-07:00

Thanks for pointing out that these documents need an update. I will put it on my todo list.
.NET + ImageMagick = Magick.NET https://github.com/dlemstra/Magick.NET, @MagickNET, Donate

Post Reply