Having problems with uploading image to Spree app

Questions and postings pertaining to the development of ImageMagick, feature enhancements, and ImageMagick internals. ImageMagick source code and algorithms are discussed here. Usage questions which are too arcane for the normal user list should also be posted here.
Post Reply
zeflonex
Posts: 1
Joined: 2018-01-27T08:06:36-07:00
Authentication code: 1152

Having problems with uploading image to Spree app

Post by zeflonex » 2018-01-27T08:10:19-07:00

I am trying to create a Spree app and i am having problems with uploading an image. I am currently on rails 5.1, latest spree edition and installed paperclip gem, unfortunately my OS is windows 10. When i try to upload the image i get this error



5 errors prohibited this record from being saved:

Attachment Paperclip returned errors for file 'index.png' - check ImageMagick installation or image source file.
Attachment Paperclip::Errors::NotIdentifiedByImageMagickError
Attachment Paperclip::Errors::NotIdentifiedByImageMagickError
Attachment Paperclip::Errors::NotIdentifiedByImageMagickError
Attachment Paperclip::Errors::NotIdentifiedByImageMagickError

What can i do about this?

User avatar
fmw42
Posts: 23670
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: Having problems with uploading image to Spree app

Post by fmw42 » 2018-01-27T12:29:55-07:00

What version of ImageMagick do you have? Are you sure it is installed correctly and compatible with your other applications. Generally imagemagick does not do uploading. So it is likely your other software that is the problem or it cannot feed the uploaded image to ImageMagick to process. Sorry I do not know Paperclip.

Post Reply