SVG href image not showing in PDF conversion

Questions and postings pertaining to the development of ImageMagick, feature enhancements, and ImageMagick internals. ImageMagick source code and algorithms are discussed here. Usage questions which are too arcane for the normal user list should also be posted here.
Post Reply
javastorme
Posts: 1
Joined: 2018-06-07T06:46:22-07:00
Authentication code: 1152

SVG href image not showing in PDF conversion

Post by javastorme » 2018-06-07T06:52:02-07:00

Hi! I've had this issue for a few days and have tried a number of things. Essentially, I'm having users edit an SVG and once they're finished, they save it back to a file path on the server. My problem is my SVG contains an href to a file in a directory. As an SVG, it can reference the file with no problem but when I convert the file to a PDF, it doesn't have the image but it does have the other SVG elements such as lines and text. Has anyone had this issue or know how to resolve?
Side note: I'm using ImageMagick in C# but the commands to do this should translate.

snibgo
Posts: 10820
Joined: 2010-01-23T23:01:33-07:00
Authentication code: 1151
Location: England, UK

Re: SVG href image not showing in PDF conversion

Post by snibgo » 2018-06-07T08:02:41-07:00

Does the SVG show correctly with Inkscape? If not, then the SVG has an error.

What delegate is ImageMagick using to render the SVG? (What does "-verbose" say?) If not Inkscape, then try it using Inkscape.
snibgo's IM pages: im.snibgo.com

Post Reply