I still need these dependencies!

Questions and postings pertaining to the development of ImageMagick, feature enhancements, and ImageMagick internals. ImageMagick source code and algorithms are discussed here. Usage questions which are too arcane for the normal user list should also be posted here.
Post Reply
zeroLee
Posts: 1
Joined: 2018-12-21T02:43:21-07:00
Authentication code: 1152

I still need these dependencies!

Post by zeroLee » 2018-12-21T03:42:43-07:00

I'm downloading ImageMagick for CentOS from:
https://imagemagick.org/script/download.php#unix

But when I run to install it:

Code: Select all

rpm -Uvh ImageMagick-7.0.8-19.x86_64.rpm
I'm still getting that I need all these dependencies:

Code: Select all

error: Failed dependencies:
	ImageMagick-libs(x86-64) = 7.0.8-19 is needed by ImageMagick-7.0.8-19.x86_64
	libMagickCore-7.Q16HDRI.so.6()(64bit) is needed by ImageMagick-7.0.8-19.x86_64
	libMagickWand-7.Q16HDRI.so.6()(64bit) is needed by ImageMagick-7.0.8-19.x86_64
	libMagickWand-7.Q16HDRI.so.6(VERS_6.0)(64bit) is needed by ImageMagick-7.0.8-19.x86_64
Or may be the term 'Failed' doesn't mean I need them but rather they are only failing? I don't know!

Help please!

User avatar
magick
Site Admin
Posts: 10909
Joined: 2003-05-31T11:32:55-07:00

Re: I still need these dependencies!

Post by magick » 2018-12-28T09:04:15-07:00

Try installing the libs first, ImageMagick-libs-7.0.8-21.x86_64.rpm.

Post Reply