Page 1 of 1

toycamera tint

Posted: 2013-10-30T14:05:08-07:00
by corbanb

I am trying to use the toycamera filter in combination with -t. From what I can see there is a bug in the code that would allow this to work correct. Below is my command and the output.

Code: Select all

$ toycamera -i 60 -o 150 -d 5 -s 10 -c 10 -S 2 -t ffa930 -a 10 in.jpg out.jpg

convert: unable to open image `ffa930': No such file or directory @ error/blob.c/OpenBlob/2643.
convert: no decode delegate for this image format `ffa930' @ error/constitute.c/ReadImage/552.
I have tried to wrap the color in quotes, add 0x or # in front and of the color and nothing seems to work for it. Is it possible hex values are not valid? Any thoughts?


Re: toycamera tint

Posted: 2013-10-30T14:14:08-07:00
by corbanb
solved it!

-fill is the option and it requires the colors to be in these formats - ... s.php#fill

Re: toycamera tint

Posted: 2013-10-30T16:02:27-07:00
by fmw42
the following should work. if not let me know.

toycamera -i 60 -o 150 -d 5 -s 10 -c 10 -S 2 -t "#ffa930" -a 10 in.jpg out.jpg

see for valid IM colors. Note that rgb(..) and hex, need to be enclosed in quotes at least on unix systems