cant run Fred scripts

A plethora of command-line scripts that perform geometric transforms, blurs, sharpens, edging, noise removal, and color manipulations.
Post Reply
phobos
Posts: 13
Joined: 2013-04-07T03:07:18-07:00
Authentication code: 6789

cant run Fred scripts

Post by phobos » 2013-11-16T17:15:14-07:00

hello!
i try to run http://www.fmwconcepts.com/imagemagick/ ... /index.php script
USAGE: peelingpaint [-m mode] [-s strength] [-g gain] infile texture outfile
my example :
<?
$run="sh/peelingpaint.sh -m scratches -s 130 -g 75 infile.jpg sh/mask1.jpg outfile.jpg 2>&1";
$run = exec($ln,$out,$err);
?>
after trying and i have :
Array ( [0] => [1] => --- UNKNOWN OPTION --- [2] => [3] => [4] => peelingpaint.sh: [5] => [6] => USAGE: peelingpaint [-m mode] [-s strength] [-g gain] infile texture outfile [7] => USAGE: peelingpaint [-h or -help] [8] => [9] => OPTIONS: [10] => [11] => -m mode mode for output; choices are: cracks (c) or scratches (s); [12] => default=cracks [13] => -s strength strength (darkness) of cracks; integer>=0; default=100 [14] => -g gain gain applied by composite mask; integer>=0; default=75 [15] => )

where error?

User avatar
fmw42
Posts: 25021
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: cant run Fred scripts

Post by fmw42 » 2013-11-16T18:24:31-07:00

phobos wrote:hello!
i try to run http://www.fmwconcepts.com/imagemagick/ ... /index.php script
USAGE: peelingpaint [-m mode] [-s strength] [-g gain] infile texture outfile
my example :
<?
$run="sh/peelingpaint.sh -m scratches -s 130 -g 75 infile.jpg sh/mask1.jpg outfile.jpg 2>&1";
$run = exec($ln,$out,$err);
?>
after trying and i have :
Array ( [0] => [1] => --- UNKNOWN OPTION --- [2] => [3] => [4] => peelingpaint.sh: [5] => [6] => USAGE: peelingpaint [-m mode] [-s strength] [-g gain] infile texture outfile [7] => USAGE: peelingpaint [-h or -help] [8] => [9] => OPTIONS: [10] => [11] => -m mode mode for output; choices are: cracks (c) or scratches (s); [12] => default=cracks [13] => -s strength strength (darkness) of cracks; integer>=0; default=100 [14] => -g gain gain applied by composite mask; integer>=0; default=75 [15] => )

where error?
Please identify your IM version and platform.

Did you follow the instructions for use with PHP on my home page at http://www.fmwconcepts.com/imagemagick/index.php.

Did you edit the file to modify it so that the path to IM is in your PATH?
Did you change the dir from "." to "/tmp"?
Does your file actually have a suffix .sh?
Did you ensure the file has executable permissions?
Do you have permissions in the sh/ subdirectory? Is that really a subdirectory or did you mean to put "bash peelingpaint ..."

Did you replace infile.jpg sh/mask1.jpg outfile.jpg with actual file names? Do you have a texture file?

Are you running the script in the same directory as the images? If not you may need to provide full paths to your files and to the script?

Have you tried running the script in a terminal window without PHP? If you cannot do that, can you provide your actual command line with the exact images and post links to your images, so that I can test with them. Or have you tried using my sample images?

This worsk just fine for me on IM 6.8.7.6 Q16


peelingpaint -m cracks -s 100 -g 75 lena3.jpg peelingtexture1.jpg tmp.jpg

as does this

peelingpaint -m scratches -s 130 -g 75 lena3.jpg peelingtexture1.jpg tmp.jpg

I am not a PHP expert but the following does not look right to me.

<?
$run="sh/peelingpaint.sh -m scratches -s 130 -g 75 infile.jpg sh/mask1.jpg outfile.jpg 2>&1";
$run = exec($ln,$out,$err);
?>
try

Code: Select all

<?php
exec(sh/peelingpaint.sh -m scratches -s 130 -g 75 infile.jpg sh/mask1.jpg outfile.jpg 2>&1,$out,$returnval);
foreach($out as $text)
{echo "$text<br>";}
?>

Bonzo
Posts: 2970
Joined: 2006-05-20T08:08:19-07:00
Location: Cambridge, England

Re: cant run Fred scripts

Post by Bonzo » 2013-11-17T01:05:29-07:00

Code: Select all

<?
$run="sh/peelingpaint.sh -m scratches -s 130 -g 75 infile.jpg sh/mask1.jpg outfile.jpg 2>&1";
$run = exec($ln,$out,$err); 
?>
As I read this you are setting $run to "sh/......." and then setting it to exec(...... Try as fmw42 says or:

Code: Select all

<?
exec("sh/peelingpaint.sh -m scratches -s 130 -g 75 $in sh/mask1.jpg $out 2>&1"); 
?>

phobos
Posts: 13
Joined: 2013-04-07T03:07:18-07:00
Authentication code: 6789

Re: cant run Fred scripts

Post by phobos » 2013-11-17T03:28:09-07:00

fmw42 wrote:
phobos wrote:hello!
i try to run http://www.fmwconcepts.com/imagemagick/ ... /index.php script
USAGE: peelingpaint [-m mode] [-s strength] [-g gain] infile texture outfile
my example :
<?
$run="sh/peelingpaint.sh -m scratches -s 130 -g 75 infile.jpg sh/mask1.jpg outfile.jpg 2>&1";
$run = exec($ln,$out,$err);
?>
after trying and i have :
Array ( [0] => [1] => --- UNKNOWN OPTION --- [2] => [3] => [4] => peelingpaint.sh: [5] => [6] => USAGE: peelingpaint [-m mode] [-s strength] [-g gain] infile texture outfile [7] => USAGE: peelingpaint [-h or -help] [8] => [9] => OPTIONS: [10] => [11] => -m mode mode for output; choices are: cracks (c) or scratches (s); [12] => default=cracks [13] => -s strength strength (darkness) of cracks; integer>=0; default=100 [14] => -g gain gain applied by composite mask; integer>=0; default=75 [15] => )

where error?

Please identify your IM version and platform.

Did you follow the instructions for use with PHP on my home page at http://www.fmwconcepts.com/imagemagick/index.php.

Did you edit the file to modify it so that the path to IM is in your PATH?
Did you change the dir from "." to "/tmp"?
Does your file actually have a suffix .sh?
Did you ensure the file has executable permissions?
Do you have permissions in the sh/ subdirectory? Is that really a subdirectory or did you mean to put "bash peelingpaint ..."

Did you replace infile.jpg sh/mask1.jpg outfile.jpg with actual file names? Do you have a texture file?

Are you running the script in the same directory as the images? If not you may need to provide full paths to your files and to the script?

Have you tried running the script in a terminal window without PHP? If you cannot do that, can you provide your actual command line with the exact images and post links to your images, so that I can test with them. Or have you tried using my sample images?

This worsk just fine for me on IM 6.8.7.6 Q16


peelingpaint -m cracks -s 100 -g 75 lena3.jpg peelingtexture1.jpg tmp.jpg

as does this

peelingpaint -m scratches -s 130 -g 75 lena3.jpg peelingtexture1.jpg tmp.jpg

I am not a PHP expert but the following does not look right to me.

<?
$run="sh/peelingpaint.sh -m scratches -s 130 -g 75 infile.jpg sh/mask1.jpg outfile.jpg 2>&1";
$run = exec($ln,$out,$err);
?>
try

Code: Select all

<?php
exec(sh/peelingpaint.sh -m scratches -s 130 -g 75 infile.jpg sh/mask1.jpg outfile.jpg 2>&1,$out,$returnval);
foreach($out as $text)
{echo "$text<br>";}
?>
imagick module version - 3.0.1
ImageMagick version - ImageMagick 6.7.3-1 2011-10-12 Q16 http://www.imagemagick.org
ImageMagick release date - 2011-10-12
Did you ensure the file has executable permissions? - yes 755
Did you replace infile.jpg sh/mask1.jpg outfile.jpg with actual file names? Do you have a texture file? - yes http://designshack.net/wp-content/uploa ... aint-9.jpg
---
everything worked in the spring 2013, now is not working.
3DREFLETSTION script is also not working properly :
with -r 20 -s on -g 10
run=convert: missing an image filename `effect_a0caaad4739d7c62ce77f80ad9fdbb98.jpg' @ error/convert.c/ConvertImageCommand/3016.
Array (
[0] => /sh/3Dreflection.sh: line 338: 3Drotate: команда не найдена
[1] => convert: unable to open image `/tmp/3Dreflect_3_8479.mpc': Нет такого файла или каталога @ error/blob.c/OpenBlob/2589.
[2] => convert: missing an image filename `vk_temp/effect_a0caaad4739d7c62ce77f80ad9fdbb98.jpg' @ error/convert.c/ConvertImageCommand/3016.
)
* (Нет такого файла или каталога - No such file or directory)
*(tmp/ - directory exists)
---
isolatetsolor script is not working properly too.
iM exsample :
http://www.fmwconcepts.com/imagemagick/ ... 0_s100.jpg
my example :
https://dl.dropboxusercontent.com/u/57057313/my/ex.jpg
with options -c red -t 10 -S 0 -s 100
---
all the other scripts are working properly.
I think that all the errors because of other versions IM.

User avatar
fmw42
Posts: 25021
Joined: 2007-07-02T17:14:51-07:00
Authentication code: 1152
Location: Sunnyvale, California, USA

Re: cant run Fred scripts

Post by fmw42 » 2013-11-17T11:41:44-07:00

My scripts are working in the command line in IM 6.8.7.6 Q16.

Unfortunately, I cannot go back to your release and test them any longer. My older versions of IM do not work properly after upgrading my delegates. Your version of IM 6.7.3.1 is about 125 versions old. Can you upgrade?

The errors seem to relate to possible permissions or or /tmp space or IM/PHP environment variables. Have you cleared your /tmp directory?

Try using my syntax and let me know what errors you get.

Did you change your environment at any time since they were working? Had you upgraded PHP or IM?

Post Reply